Recent Update and Strange SEO Issue

Epicster

Power Member
Jan 2, 2012
754
294
Hello, there

So, with the latest update, 2 of my main pages got disappeared overnight but there is one strange thing which I am trying to figure out what it is.

All my other pages except 2 are still ranking where they were before the update.

I checked google and found out that if I put my keywords into search, the site shows up in search page 1, page 2 everywhere. But if I put the URL directly into the google search, it doesn't show any results for my site. It is happening for all my site URLs, including the root.

NO Manual penalties, NO Partial Penalties, Site is not hacked, Checked index, robots, meta tags. Refreshed cache, Inspect URL.

No Errors, No Issues! Reported

Is anyone aware of anything like this?
 
I just checked and all my sites are fine so far. Is that happens today?
 
In last update one of my sites vanished from the search. But after 2 weeks its back to normal. I think this is normal. Just give little more time and recheck again after few days.
 
In last update one of my sites vanished from the search. But after 2 weeks its back to normal. I think this is normal. Just give little more time and recheck again after few days.
My site is not completely vanished, only 2 pages, but my main concern is this strange thing, keywords ranking but if I put the ranking URL or my site root URL into the Google search, it doesn't show any results for my site.
 
I agree. Wait until December 2, please don't change anything until that date. Just wait for the update to settle before doing anything or draw nefarious conclusions.
 
I agree. Wait until December 2, please don't change anything until that date. Just wait for the update to settle before doing anything.
I know, but I am just curious about this strange issue and was looking for answers if anyone else got this problem or not.
 
I know, but I am just curious about this strange issue and was looking for answers if anyone else got this problem or not.
I usually don't manually check all my single pages so I don't know. But I know that I had a parasite which was ranking for my brand keyword. It disappeared for about 12 hours, and then came back (even though on a lower position)
 
I usually don't manually check all my single pages so I don't know. But I know that I had a parasite which was ranking for my brand keyword. It disappeared for about 12 hours, and then came back (even though on a lower position)
I am not talking about the brand keywords, but about the URL. For normal queries and brand keywords, i am ranking very well. But if I search, https://www.example.com

it doesn't give out any results for my site.
 
Faced similar issue, when checking indexing use "site:" sometimes the link would not show up, after changing ips, it showed up. Also, it might be a temporary thing, its better if you wait for some time.
 
Faced similar issue, when checking indexing use "site:" sometimes the link would not show up, after changing ips, it showed up. Also, it might be a temporary thing, its better if you wait for some time.
Lol, I am not checking indexing, I clearly said, no indexing issue here. It's just if I search for a keyword, the site shows up but if I put the URL directly or the root URL, it doesn't show at all on google.
 
Lol, I am not checking indexing, I clearly said, no indexing issue here. It's just if I search for a keyword, the site shows up but if I put the URL directly or the root URL, it doesn't show at all on google.
ok, but I had kinda similar vanishing experience. So, when you enter your URL directly its not showing up. What about, when you enter it with the site: prefix?
 
ok, but I had kinda similar vanishing experience. So, when you enter your URL directly its not showing up. What about, when you enter it with the site: prefix?
You didn't read I guess,

Site Operator - It shows all indexed pages
Keywords / Brand Anchors - It shows the ranking page - ALl pages are ranked where they were, only 2 pages are affected.
Naked URL - Doesn't show anything related to my site.
 
You didn't read I guess,

Site Operator - It shows all indexed pages
Keywords / Brand Anchors - It shows the ranking page - ALl pages are ranked where they were, only 2 pages are affected.
Naked URL - Doesn't show anything related to my site.
Oh ok, my bad, this is a weird problem, intrigued. Last question, did you try checking the naked url with different ips/proxies?
 
I got your point but I will suggest you change your content, images, design accordingly, and try to re-index your pages to check their ranking again.
 
Hello Everyone! I am facing the same issue. Longstanding ranking pages started to vanish from roughly the 5th of October. The pages are still indexable in search console but they completely disappeared from SERPs. Good content, authoritative websites. All my 4 websites are somehow affected. Anyone as a solution yet?
 
Back
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features and essential functions on BlackHatWorld and other forums. These functions are unrelated to ads, such as internal links and images. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock