1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem With My Website

Discussion in 'White Hat SEO' started by mikev, Mar 29, 2017.

  1. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    Hello, every of my 4 sites on my hosting account gets this message when I type in the URL:


    Warning: require(/home2/miho/public_html/wp-includes/post.php): failed to open stream: No such file or directory in /home2/miho/public_html/wp-settings.php on line 167

    Fatal error: require(): Failed opening required '/home2/miho/public_html/wp-includes/post.php' (include_path='.:/opt/php54/lib/php') in /home2/miho/public_html/wp-settings.php on line 167

    I am really scared I might lose all of my income.

    If some of you has experience with this, please help!

    Thanks!
     
  2. BassTrackerBoats

    BassTrackerBoats Super Moderator Staff Member Moderator Jr. VIP

    Joined:
    Mar 10, 2010
    Messages:
    15,887
    Likes Received:
    29,181
    Occupation:
    I don't actually have a job
    Location:
    Not England
    Home Page:
    Get support at your host to help you out while you are waiting for an answer here... if they are any good they will take care of it for you.
     
  3. MisterF

    MisterF Jr. VIP Jr. VIP

    Joined:
    Nov 29, 2009
    Messages:
    6,248
    Likes Received:
    4,740
    Occupation:
    Conference Organiser, Business Advisor.,
    Location:
    JADIP
    Home Page:
    Are you using anything nulled ?

    When did you last update Wordpress?
    Was it an auto install and update or did you download it and do it manually?
     
  4. jamescollins

    jamescollins Jr. VIP Jr. VIP

    Joined:
    Feb 5, 2016
    Messages:
    135
    Likes Received:
    34
    Location:
    Costa Blanca
    Are they all the same perhaps nulled themes or different?
     
  5. MisterF

    MisterF Jr. VIP Jr. VIP

    Joined:
    Nov 29, 2009
    Messages:
    6,248
    Likes Received:
    4,740
    Occupation:
    Conference Organiser, Business Advisor.,
    Location:
    JADIP
    Home Page:
    Or as BTB says, if it's all on the same hosting, sounds like a conflict on their system.
     
    • Thanks Thanks x 1
  6. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    Thanks for the response. I will do anything to resolve my issue.

    I will contact HostGator Asap.
     
  7. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    I did not updated Wordpress manually. Maybe it was an auto install.

    I am using theme and plugin from GPLvault on my site that is actually normal. There are absolutely no issues with my site that uses themes and plugins from that site if you consider them to be nulled.
     
  8. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    On my sites that these errors appear, I am not using any nulled themes or plugins
     
  9. adityaradea

    adityaradea Registered Member

    Joined:
    Feb 21, 2017
    Messages:
    74
    Likes Received:
    20
    Gender:
    Male
    how about your username and password, did you use weak password like admin and admin123, now so many attacker malware come to get acces login with bruto force attack. in my case, i use ithemes security pro original to protect my website from them
     
  10. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    Nah, my username and password is actually pretty complicated.
     
  11. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    Anyone else?
     
  12. mikev

    mikev Newbie

    Joined:
    May 13, 2015
    Messages:
    11
    Likes Received:
    0
    I managed to fix this issue. Thanks for the support.

    I can now login to my wp-admin.

    However, how can it be possible to have problem with the theme on every site?

    Fatal error: Call to undefined function sydney_slider_template() in /home2/mixe/public_html/site-name/wp-content/themes/sydney/header.php on line 57

    This is now the error I receive. But, when I change the theme the problem goes away.

    What was the cause of this problem? How can I prevent this from happening from in the future? It would be a long way to fix and redesign every single site to detail.
     
  13. adityaradea

    adityaradea Registered Member

    Joined:
    Feb 21, 2017
    Messages:
    74
    Likes Received:
    20
    Gender:
    Male
    it seems that the problem come from header.php of your theme, usually hapened when your theme confliq with one or more plugin that modified your header file
     
  14. nickchernets

    nickchernets Jr. VIP Jr. VIP

    Joined:
    Mar 14, 2017
    Messages:
    112
    Likes Received:
    10
    Gender:
    Male
    Home Page:
    Contact your host, seem to be their problem