1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help with my new domain hosted on Godaddy

Discussion in 'Web Hosting' started by ewriterdan, Jun 11, 2013.

  1. ewriterdan

    ewriterdan Newbie

    Joined:
    Jun 10, 2013
    Messages:
    49
    Likes Received:
    2
    I recently invested into starting my own website, but have encountered an issue where I cannot seem to get my wordpress blog to work on it. I get a 404 error stating that the website has no content uploaded onto it, and since I am a complete newbie to creating websites and wordpress blogs I really need someone's help with this matter. I have gone through the installation process and apparently succeeded, but still no content on the webpage. If you can please help me I would really appreciate it, and possibly return the favour somehow?

    Thanks in advance,
     
    Last edited: Jun 11, 2013
  2. gergo2007

    gergo2007 Jr. VIP Jr. VIP Premium Member

    Joined:
    Nov 2, 2010
    Messages:
    805
    Likes Received:
    213
    Maybe you installed wordpress in a folder. Check that. If so add the folders name after your domain like this, to see if it works: domain.com/foldername
     
  3. Jacal

    Jacal Newbie

    Joined:
    May 16, 2012
    Messages:
    27
    Likes Received:
    15
    Location:
    UK
    Seems like a known issue. If you've got Windows hosting then try the following, taken from GoDaddy's forums:

    " If your database is set up correctly and your wp-config file is accurate, and you are experiencing this problem, you will need to change the 404 page settings through your GoDaddy account. Under the "My Products" section in the side navigation, click hosting. Scroll down to the Products>Web Hosting section on the page and click the round green "Launch" button to the right of the appropriate url. This will take you to the Hosting Control Center. Under the Settings section, click "404 Page Behavior"and choose either homepage or create and choose a custom 404 page for your site. The GoDaddy default 404 page is the culprit, so by changing this setting your links will work! That's it."

    Also, if you're serious about your website then run away from GoDaddy's hosting... fast. If you're on any of their shared hosting plans then there will come a point that you go insane while attempting to even create a post on the blog.

    EDIT: Pasted text was black and therefore invisible -.-
     
  4. ewriterdan

    ewriterdan Newbie

    Joined:
    Jun 10, 2013
    Messages:
    49
    Likes Received:
    2
    Thanks for your response! :) I will try this out and report back if my problem is resolved. Yes I am using Godaddy for hosting and I have signed up for 2 years of it. Where would you recommend that I switch to if it is possible?

    Thanks again,
    Dan,
     
  5. ewriterdan

    ewriterdan Newbie

    Joined:
    Jun 10, 2013
    Messages:
    49
    Likes Received:
    2
    :( They told me to wait for 5 mins whilst they made the changes, however to no avail after waiting a total of half an hour now. Any other suggestions?
     
  6. Jacal

    Jacal Newbie

    Joined:
    May 16, 2012
    Messages:
    27
    Likes Received:
    15
    Location:
    UK
    Hopefully they managed to get it sorted! As for who I'd recommend if you switch - it seems to be good etiquette here on the forum not to make any specific recommendations. However, if you go to the Journey section you'll see plenty of 'bought hosting with xxxxx' posts and pretty much everyone here knows what they're talking about when it comes to hosting. I hate to bash GoDaddy's hosting but I have sore experiences both with the hosting itself and the support that follows it.

    As for other suggestions, from what I read last night the quickest and easiest short term fix would be to swap out your Windows hosting for Linux on the same account. If I remember rightly, this is a fairly simple process at GD and the Linux hosting does not suffer from the same issues.
     
    • Thanks Thanks x 1
  7. ewriterdan

    ewriterdan Newbie

    Joined:
    Jun 10, 2013
    Messages:
    49
    Likes Received:
    2
    Thanks for the advice! I will try that now.
     
  8. ewriterdan

    ewriterdan Newbie

    Joined:
    Jun 10, 2013
    Messages:
    49
    Likes Received:
    2
    I believe that I have now fixed this problem as I can now view my website fine :) All I did was change the hosting from windows to linux.