Indexing Problem!! What to do!!

AliceInSEOLand

Registered Member
Joined
Dec 11, 2021
Messages
93
Reaction score
212
Definitely an issue with Google. And I believe it is part of their algorithm to intentionally index new websites (freshly made, or from expired domains) very slowly, especially when they detect that you're publishing so many articles or trying to get them indexed quickly.

I've been working on this new website project of mine since last November. Top-quality articles, backed with references/citations, written by native writers, bla bla bla. The domain doesn't have any toxic backlink history nor is there any penalty. Published 30+ articles intermittently - like several days apart from each other. It is only mid-December that Google finally indexed the blog's main page, and just 2 blog posts. The rest they just won't index them.

I tried the Google Index API trick, manually submitting it in GSC, and so on. But it just won't get indexed. I kept doing the API trick and submitting it via GSC, pinging them, and many more, but it just won't do it.

Now the reason why I believe it is part of their algorithm is that, in the GSC crawl reports, it is showing a high crawl rate and requests every single day, even today.

However, in the coverage section, the last 'crawled' date for some pages was in early January. How is it possible that I have a high crawl rate daily but the last crawl date for some pages is in early January? It doesn't make sense, doesn't it? And later one more posts was indexed in mid January... But the funny thing is it doesn't show when I do that site: query search of the link. But in GSC when I try to inspect that link, it tells me the URL is in Google's index. Wtf eh?

Edit: Just found out Google has finally indexed 1 more post, and 1 category page after so long. But again, they aren't showing in query searches (site: )
 
Last edited:

Whome

Junior Member
Joined
Nov 21, 2009
Messages
117
Reaction score
66
Aged old non-drop domains seems to be working hence why most of spamdexing sites I see are on it..
 

C45HC0W

Regular Member
Joined
Jan 30, 2019
Messages
424
Reaction score
139
I have the same problem. Actually my backlink is indexed and comes right away when you google the keywords but my page itself is not indexed.
I just checked in the search console the page is crawled but not indexed for somw reason. I just applied for a reconsideration of indexing this url. I tell you if this fixed my problem or not
 

C45HC0W

Regular Member
Joined
Jan 30, 2019
Messages
424
Reaction score
139
@Didou So after requesting indexing via the search console the two pages I commited are indexed now.
 

Marcelinho98

Newbie
Joined
Aug 5, 2020
Messages
31
Reaction score
19
Definitely an issue with Google. And I believe it is part of their algorithm to intentionally index new websites (freshly made, or from expired domains) very slowly, especially when they detect that you're publishing so many articles or trying to get them indexed quickly.

I've been working on this new website project of mine since last November. Top-quality articles, backed with references/citations, written by native writers, bla bla bla. The domain doesn't have any toxic backlink history nor is there any penalty. Published 30+ articles intermittently - like several days apart from each other. It is only mid-December that Google finally indexed the blog's main page, and just 2 blog posts. The rest they just won't index them.

I tried the Google Index API trick, manually submitting it in GSC, and so on. But it just won't get indexed. I kept doing the API trick and submitting it via GSC, pinging them, and many more, but it just won't do it.

Now the reason why I believe it is part of their algorithm is that, in the GSC crawl reports, it is showing a high crawl rate and requests every single day, even today.

However, in the coverage section, the last 'crawled' date for some pages was in early January. How is it possible that I have a high crawl rate daily but the last crawl date for some pages is in early January? It doesn't make sense, doesn't it? And later one more posts was indexed in mid January... But the funny thing is it doesn't show when I do that site: query search of the link. But in GSC when I try to inspect that link, it tells me the URL is in Google's index. Wtf eh?

Edit: Just found out Google has finally indexed 1 more post, and 1 category page after so long. But again, they aren't showing in query searches (site: )
That's the exact same problem I have. I also started a site in November 21 on an aged domain. At first, the traffic went up and the articles appeared on page one. Now they are on page 6-10 and even if the GSC says that 61 pages are indexed, only 4 are shown if I do the "site:" query. Maybe you can send me an PM and we can check our websites? Maybe we have the same problem somehow..
 

Rafiki59

Junior Member
Joined
Jan 14, 2019
Messages
168
Reaction score
80
That's the exact same problem I have. I also started a site in November 21 on an aged domain. At first, the traffic went up and the articles appeared on page one. Now they are on page 6-10 and even if the GSC says that 61 pages are indexed, only 4 are shown if I do the "site:" query. Maybe you can send me an PM and we can check our websites? Maybe we have the same problem somehow..

You have the 4 results penalty dude https://www.blackhatworld.com/seo/anyone-site-only-4-results-indexed-penalty-now.1318746/
It's a death penalty, your site is like non-existent in google
 
Top