Sudden Ranked Drop? Google Algo Update?

My keyword from in 2,3,4 disappeared to nowhere. No link building, nothing at all. These pages were on top positions more than 6 months
 
Ahrefs also showing many lost keywords for me right now on multiple projects. Even brand keywords show lost position :D (not true tho by a manual check).
 
https://support.google.com/webmasters/thread/28619804?hl=en

Look at those wise experts.

>Hundreds of threads from hundreds of people with THE SAME issue since december.
>Arguing with people all the time - "it's your fault, not Google", "haha improve your poor content bro and stop whining".
>After two months - "hmm it seems like a Google bug, weird..."

This is incredible. This is just incredible...

EXACTLY. Always pointing the finger at us. All our SEO tools are catching up on it but "Google hasn't done a big update"...
 
If BBC lost pos, then wtf we (ordinary) need to do better? buy the whole internet and put backlinks on all website outhere to our main website?
 
Last edited:
It`s the problem on Ahrefs side, I asked their support:
 

Attachments

  • ahrefs.png
    ahrefs.png
    25.4 KB · Views: 46
EXACTLY. Always pointing the finger at us. All our SEO tools are catching up on it but "Google hasn't done a big update"...
Those bastards
It`s the problem on Ahrefs side, I asked their support:

Honestly, I don't think it's the only issue. In fact, I searched for my keywords in different devices from various locations. Keywords lost like a hell
 
Guys , do u think that this is happening to new sites only ? (Less than 6 month old)?
Anyone tried to change the content completely ? How were the effects ?
 
Guys , do u think that this is happening to new sites only ? (Less than 6 month old)?
Anyone tried to change the content completely ? How were the effects ?

my website is 4 years old. the content was solid. the page was in 2nd position for more than 6 months. now it's gone not to 5th, or 8th position, but nowhere...
 
my website is 4 years old. the content was solid. the page was in 2nd position for more than 6 months. now it's gone not to 5th, or 8th position, but nowhere...
I think that's because it's not in index /or in sandbox index, just as like my sites ... Tried to reindex, create new pages , but it still doesn't appear nowhere .. Few days ago I could see 3-4 results using site:xxx.xxx now it's showing only main domain ) very curious why is this , I think it was not seen never before in bhw ...
 
Speaking of lost keywords...

One of my big sites was first since I built it for "site name" query, because it is site-name .com, and title is Site Name | Blabla bla... (brandable name, not many queries unless searching for exactly my site).

Now.. I've lost the "site name" rank, nowhere to be found :D

Results are packed with "something site name something" amazon and books results
 
Hi everyone,

I had 2 sites. The first site before Sept had a great rank. Almost rank on page 1. But suddenly on Sept just drop to nowhere. This site all pages were indexed on the google result.
The second site in the same niche has ranked on page 2. However, on Jan all those rank just is gone. The second site if check on site:domainname.tld only be showed 5 pages.

Does anyone here have the ranks back to their positions yet?
 
Tengo varios sitios web afectados, siempre he pensado que es un problema con la indexación. Una web cayó el 16 de diciembre, al ver que no recuperé hice la redirección 301, el dominio nuevo comenzó a tener mucho tráfico. De repente hace dos días comenzo a perder muchas palabras clave y parece de nuevo que penalizaron.
 
The more research I do on this, I feel this was not a coincidence. Since I am seeing more blogs/stores still have rankings and that were not affected. Now it seems like new domains will take months to index thoroughly. Maybe it has to do with the update.

I also had some theories it has to do with:
Content (too much duplicate content or spam)
Barely any backlinks (got outranked by competition that have powerful backlinks
Not using www. in domain?
No original content/no value

Doing more research on this though.
 
Last edited:
I just updated an article and in the Google results, it says that it was created in 2015. I don't even know where it took the year since there is no mention of 2015 anywhere in the page .. I have never been more confused in my life. And of course, Google actually thinks it's an article created in 2015, so it got nicely thrown to the second page.
 
Hello to me, just like most of you have fallen.

Strange is that the 8 posts I added in February are indexed and they are not in the top 200 :/
It doesn't work for them to show up.

Browsing the google webmaster I encountered hundreds of such links in index.

Do any of you know how to get rid of such a thing?

tyhjpg_qaenrrx.jpg
 
Back
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features and essential functions on BlackHatWorld and other forums. These functions are unrelated to ads, such as internal links and images. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock