1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! php not working after reboot?

Discussion in 'PHP & Perl' started by xNotch, Feb 7, 2017.

Tags:
  1. xNotch

    xNotch Registered Member

    Joined:
    Sep 16, 2014
    Messages:
    81
    Likes Received:
    19
    Im currently trying to install open web analytics , on apache, using this tutorial and everything works great up until the point where I try to reboot the server after which instead of displaying the webpage my browsers trys to download the php file. Anyone have any ideas on what might cause this?
     
  2. littlewebdragon

    littlewebdragon Jr. VIP Jr. VIP

    Joined:
    Dec 30, 2007
    Messages:
    1,707
    Likes Received:
    1,040
    Occupation:
    Occupation
    Location:
    Location
    Check up your .htaccess file first, try even removing it temporary.
     
  3. tasburrfoot

    tasburrfoot Regular Member

    Joined:
    Dec 16, 2008
    Messages:
    323
    Likes Received:
    152
    What OS are you on? You'll need to sudo systemctl start *whateverphpserviceyouuse* && systemctl enable *thesamephpservice*
     
  4. xNotch

    xNotch Registered Member

    Joined:
    Sep 16, 2014
    Messages:
    81
    Likes Received:
    19
    was on ubuntu 16.04. I downgraded to 14.04 and that seems to fix the issue.
     
  5. somethingclever

    somethingclever Newbie

    Joined:
    Nov 26, 2008
    Messages:
    24
    Likes Received:
    4
    Gender:
    Male
    Occupation:
    Anything that puts money in my pocket
    Location:
    in the Ether
    Home Page:
    Before you downgraded did you check your error logs? i use fedora, so my logs are located at /var/log/httpd
     
  6. seohug

    seohug Jr. VIP Jr. VIP

    Joined:
    Feb 14, 2011
    Messages:
    343
    Likes Received:
    61
    Gender:
    Male
    Occupation:
    Automator
    Location:
    UK
    Home Page:
    Looks like the upgrade broke compatibility with php interpreter somehow and site starting serving .php as files instead of parsing them. What very of PHP are you running?