1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Flaws open gates to WordPress en-masse SEO beat-down

Discussion in 'BlackHat Lounge' started by ajpis, Jun 2, 2014.

Tags:
  1. ajpis

    ajpis Regular Member

    Joined:
    Aug 5, 2013
    Messages:
    251
    Likes Received:
    314
    Location:
    UK
    Just found this article

    Wordpress sites running the popular All in One SEO Pack plugin could have search rankings beaten down by readers and malicious code injected into pages due to dangerous vulnerabilities patched yesterday.
    The flaws allowed hackers to launch privilege escalation and cross site scripting attacks against vulnerable sites running old versions below 2.1.6. The plugin has been downloaded nearly 19 million times.


    Securi web dev and security analyst Marc-Alexandre Montpas disclosed the flaws found during a code audit to plugin developers and urged users to upgrade.
    "If your site has subscribers, authors and non-admin users logging in to wp-admin ... if you have open registration, you are at risk," Montpas said in a post.
    "In the first case, a logged-in user, without possessing any kind of administrative privileges could add or modify certain parameters used by the plugin [including] the post?s SEO title, description and keyword meta tags.
    "... we also discovered this bug can be used with another vulnerability to execute malicious Javascript code on an administrator?s control panel [which] means that an attacker could potentially inject any JavaScript code and do things like changing the admin?s account password to leaving some backdoor in your website?s files in order to conduct even more 'evil' activities later."
    The plugin was used to easily configure WordPress sites for search engine optimisation including link and meta tag generation.
    The flaws were some of a laundry list affecting WordPress plugins which users often failed to patch.
    In March, security firm Netcraft said it detected hacked WordPress blogs used to launch 12,000 phishing attacks in February alone. Many of the 27 million WordPress sites were vulnerable to brute force password attacks due to the "predictable location of the administrative interface and the still widespread use of the default 'admin' username", it said.
    TimThumb was the most infamous vulnerable plugin in recent history. The image resizing utility allowed attackers to execute arbitrary PHP code in the image directory which facilitated the foisting of malware such as the defunct BlackHole exploit kit on many thousands of WordPress websites.
     
    • Thanks Thanks x 1
  2. OnFire25

    OnFire25 Registered Member

    Joined:
    Mar 24, 2008
    Messages:
    67
    Likes Received:
    213
    For Noobs

    and to clarity the OP is referring to the current version of "all-in-one-seo-pack" [Requires: 3.3 or higher, Compatible up to: 3.9.1 {WP}, Last Updated: 2014-6-2, Downloads: 18,567,619] and not WP itself.

    Yeah I know its crazy some of us remember WP 2.1.6 way way back in 2006



    C Ya
     
  3. The Scarlet Pimp

    The Scarlet Pimp Senior Member

    Joined:
    Apr 2, 2008
    Messages:
    883
    Likes Received:
    3,320
    Occupation:
    Chair moistener.
    Location:
    Cyberspace
    i'm still running old versions of wp. the latest one doesn't display correctly for some reason.