1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yahoo site explorer - some weird results

Discussion in 'Black Hat SEO' started by rankdominator, Jul 30, 2011.

  1. rankdominator

    rankdominator Junior Member

    Joined:
    Dec 18, 2009
    Messages:
    117
    Likes Received:
    67
    Is it just me or is Yahoo site explorer giving some weird results lately.
    Specifically relating to backlink counts.

    Take a loot at the following site

    Code:
    https://siteexplorer.search.yahoo.com/search;_ylt=A0oG7zUoaTRO9DcAXhzal8kF?p=gerrycharlottephelps.com&bwmf=s&bwmo=d&bwm=i
    
    The site Im checking is gerrycharlottephelps.com
    So if I take a look at the inlinks - it lists them as 16,909

    As soon as I click back on the Pages button, the inlinks drops to 1!!!

    Does that happen to anybody else?

    There are a number of similar sites like this.

    Also, If I go directly to siteexplorer and type in the Url - the inlinks is 1?

    Why the huge difference if going via the direct link?
     
  2. rankdominator

    rankdominator Junior Member

    Joined:
    Dec 18, 2009
    Messages:
    117
    Likes Received:
    67
    Anybody - bump bump....
     
  3. kvmcable

    kvmcable Supreme Member

    Joined:
    Dec 28, 2010
    Messages:
    1,355
    Likes Received:
    2,815
    Occupation:
    24 year business owner - old school dude
    Location:
    KFC - BW3
    What do you expect when the domain expired in 2010, was available and just purchased in August 2011 but the buyer still has it parked?

    Look at those old links they're 2010 and older. You're looking at links from the old site before the domain expired. There aren't any links now because there isn't a current site running.
     
  4. VIC SEO

    VIC SEO Elite Member

    Joined:
    Feb 19, 2010
    Messages:
    2,156
    Likes Received:
    363
    Gender:
    Male
    Occupation:
    SEO Specialist
    Location:
    iSynergyMedia
    Home Page:
    Yahoo site explorer usually gives many accurate results so you can't just say that it has gone berserk just becuase it did not work well for your site. There might be some issues with your site, so probably fix those and check up again.