Issue with Keywords Everywhere

RoyCooper

Junior Member
Joined
Mar 2, 2017
Messages
108
Reaction score
7
When I copy/paste a bunch of Keywords using the "Bulk Upload Keywords" option, I find that after running the metrics I get less keywords back.

So right now I've copy/pasted there 1035 keywords, but after the metrics it returns only 900 keywords. This also happens with 100 keywords, as only 97 are returned after metrics are run.

At first I thought it was automatically eliminating keywords with zero monthly searches, but found out that's not true. Several, if not all, of the keywords with zero monthly searches are shown.

Does anyone know why this happens?
 

zedaenk

Regular Member
Joined
Apr 21, 2016
Messages
264
Reaction score
66
Some of your keywords not unique. Which means, there is double or duplicate keywords. So KE eliminate one of them. So re-check your keywords again and make sure there is no double keywords. You can check using Excels for remove duplicate keywords.
 

RoyCooper

Junior Member
Joined
Mar 2, 2017
Messages
108
Reaction score
7
Actually I thought I did remove duplicates before uploading, but I'm second guessing now.
 

RoyCooper

Junior Member
Joined
Mar 2, 2017
Messages
108
Reaction score
7
I'm using Keysearch at the moment as well, however for a pre selection, and not waste my daily limits, I use Keywords Everywhere first.
 

RoyCooper

Junior Member
Joined
Mar 2, 2017
Messages
108
Reaction score
7
Just had a second look it does seem like it removes duplicates and that was the reason.
I was only checking duplicates after that stage, that's why I didn't notice it before.
 
Top