1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[HELP] iMacro Twitter Auto-Favoriter skipping.

Discussion in 'Twitter' started by MisterSuprm, Oct 21, 2014.

  1. MisterSuprm

    MisterSuprm Registered Member

    Joined:
    Apr 15, 2014
    Messages:
    50
    Likes Received:
    2
    So I have began my daily routine of favoriting targeted content and boom, the Macro was not doing anything. So I have easily changed the "B" to "BUTTON" which has fixed the issue, however the Macro started to skip a LOT of tweets which defeats the purpose pretty much.

    Here is what I am using, any ideas why it's skipping?

    Code:
    SET !TIMEOUT_PAGE 1
    SET !LOOP 1
    SET !ERRORIGNORE YES
    SET !VAR1 {{!LOOP}}
    TAG POS={{!VAR1}} TYPE=BUTTON ATTR=TXT:Favorite
    WAIT SECONDS=2.5
    URL GOTO=javascript:window.scrollBy(0,350) 
    
    Here is a Screenshot:
    http://i.imgur.com/IwEXXeJ.png

    Edit:

    When I remove the "ERRORIGNORE" here is what I get:

    Code:
    RuntimeError: element BUTTON specified by TXT:Favorite was not found, line 4 (Error code: -921)
    Could it be that they have changed the buttons to multiple different versions? So not just "ATTR=TXT:Favorite" but "ATTR=TXT:Favorite<SP>1" "ATTR=TXT:Favorite<SP>2" and so forth? :/

    Thanks in Advance,
     
    Last edited: Oct 21, 2014
  2. ichl13

    ichl13 Newbie

    Joined:
    Aug 12, 2012
    Messages:
    27
    Likes Received:
    8
    Just noticed the same problem. Let me know if you find the fix. Seems to be skipping tweets randomly which is odd.
     
  3. joeladouille

    joeladouille Regular Member

    Joined:
    Jul 12, 2014
    Messages:
    210
    Likes Received:
    90
    The construction of your iMacros is odd. You should do this instead:

    - Search for your targeted content
    - Use a separated iMacros to load a lot of Tweets

    Code:
    URL GOTO=javascript:window.scrollBy(0,20000)
    - When you hit the limit of Tweets loaded, try this:

    Code:
    TAG POS={{!LOOP}} TYPE=BUTTON ATTR=TXT:Favorite
    WAIT SECONDS=2.5
    
     
  4. technetium

    technetium Registered Member

    Joined:
    Jul 16, 2012
    Messages:
    72
    Likes Received:
    36
    The newest imacros update is a piece of shit. After wrestling with it for way too long, I fixed all my macros by going back to version 8.8.2 from here https://addons.mozilla.org/en-US/firefox/addon/imacros-for-firefox/versions/

    Disabled automatic extension updates also.

    Instead of having my scripts get screwed up every couple months because of an update, I think I will try leaving everything alone that works and update if something breaks.
     
    • Thanks Thanks x 1
  5. MisterSuprm

    MisterSuprm Registered Member

    Joined:
    Apr 15, 2014
    Messages:
    50
    Likes Received:
    2
    Did you have to make any alterations to your Macros?

    I re-rollled to 8.8.2 however the Macros are still broken :/
     
  6. MisterSuprm

    MisterSuprm Registered Member

    Joined:
    Apr 15, 2014
    Messages:
    50
    Likes Received:
    2
    Any fix yet? Still not working for me :/
     
  7. BlackHatNub

    BlackHatNub Newbie

    Joined:
    Oct 27, 2014
    Messages:
    1
    Likes Received:
    0
    I'm quite new to imacro and using it on twitter. I was using some coding that was found on BHW and I have found that my macros for auto-favouriting is skipping. I thought it was something that I was doing!I've been seeing shorter macro on BHW but I just can't get it to run. When I try to use this code, it just wont work. I wish I could get to (I set loop to 50)


    Thoughts guys?
     
  8. ichl13

    ichl13 Newbie

    Joined:
    Aug 12, 2012
    Messages:
    27
    Likes Received:
    8
    Can anyone post a fix?
     
  9. maranzamax

    maranzamax Newbie

    Joined:
    Jun 11, 2014
    Messages:
    38
    Likes Received:
    8
    Location:
    Italy
    I just turned to 8.3.0 (found the info in another post) and things seem to be a little better now...
     
  10. samcognito

    samcognito Newbie

    Joined:
    Aug 28, 2014
    Messages:
    3
    Likes Received:
    0
    Hey guys

    i'm using imacros 8.0.7. in chrome for macos and tried this but it doesnt favorite tweets on my search result page. i dont get an error message it just dont favorite the tweets.

    any suggestions?
     
  11. maranzamax

    maranzamax Newbie

    Joined:
    Jun 11, 2014
    Messages:
    38
    Likes Received:
    8
    Location:
    Italy
    Try switching to mozilla, it's much better than chrome for imacros.
     
  12. ichl13

    ichl13 Newbie

    Joined:
    Aug 12, 2012
    Messages:
    27
    Likes Received:
    8
    Have you guys found a solution to the skipping?
     
  13. technetium

    technetium Registered Member

    Joined:
    Jul 16, 2012
    Messages:
    72
    Likes Received:
    36
    Oh crap, haven't been on in a while.

    I used the code from OP, and it skipped for me also.

    I changed it to the following, and now it is hitting them all. Give it a shot.

    The downside is it also unfavorited the few that I had already favorited, but this shouldn't be much of a problem in practical application.

    Code:
    SET !TIMEOUT_PAGE 1
    SET !LOOP 1
    SET !ERRORIGNORE NO
    SET !VAR1 {{!LOOP}}
    TAG POS={{!VAR1}} TYPE=BUTTON ATTR=CLASS:ProfileTweet-actionButton<SP>js-actionButton<SP>js-actionFavorite<SP>js-tooltip
    WAIT SECONDS=2.5
    URL GOTO=javascript:window.scrollBy(0,10000)