Cpanel problem

Discussion in 'Web Hosting' started by lmarton, Jun 14, 2018.

Tags:
  1. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    Hi,

    I want to add a new domain to cpanel via WHM and i get this error:

    "Account Creation Status: failed

    Missing DEFMOD Config Line in /etc/wwwacct.conf, please reconfigure with Edit Setup. at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 534. "

    I've added hundreds of new domains before this and never had a single problem..
    I searched on google but nothing...
    What can I do now?
     
  2. NotAllenTuring

    NotAllenTuring Jr. VIP Jr. VIP

    Joined:
    Jun 3, 2015
    Messages:
    607
    Likes Received:
    856
  3. HudsonWebServices

    HudsonWebServices Jr. VIP Jr. VIP

    Joined:
    Nov 28, 2015
    Messages:
    1,193
    Likes Received:
    229
    Location:
    Texas, US
    Home Page:
    Doing a quick google search, http://www.webhostingtalk.com/showthread.php?t=95907
     
  4. Gogol

    Gogol Jr. VIP Jr. VIP

    Joined:
    Sep 10, 2010
    Messages:
    4,333
    Likes Received:
    3,823
    Gender:
    Male
    Occupation:
    Dreaming
    Location:
    Pale Blue Dot
    Home Page:
    Yepp that is what I suggest too. They charge for the license per month, so they should fix it for you. I will not recommend you to fix the problem manually.
     
  5. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    HudsonWebServices

    I saw this already but I don't know where to type this:

    "2. Type "pico /etc/wwwact.conf"
    3. Add the following line "DEFMOD Xskin" (replace Xskin with the default theme)."

    So i need to contact to suport...I didn't want to contact because I have bh sites but maybe doesn't matter...
     
  6. Mr Crabs

    Mr Crabs Junior Member

    Joined:
    May 24, 2018
    Messages:
    133
    Likes Received:
    127
    Gender:
    Male
    Location:
    Bikini Bottom
    That would be in SSH, you a root admin on a VPS or just a reseller on reseller hosting?

    Try your hostings support, cPanels support is absolutely dire, they make you pay for priority support, if not you will be waiting a week for a reply.
     
  7. Gogol

    Gogol Jr. VIP Jr. VIP

    Joined:
    Sep 10, 2010
    Messages:
    4,333
    Likes Received:
    3,823
    Gender:
    Male
    Occupation:
    Dreaming
    Location:
    Pale Blue Dot
    Home Page:
    In your root SSH shell perhaps? I will not recommend this nevertheless.
     
  8. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    root admin but I can't connect via putty...
    When I need to type my password I can't write or copy-paste anything...I don't know whats the problem... frustrating...
     
  9. Gogol

    Gogol Jr. VIP Jr. VIP

    Joined:
    Sep 10, 2010
    Messages:
    4,333
    Likes Received:
    3,823
    Gender:
    Male
    Occupation:
    Dreaming
    Location:
    Pale Blue Dot
    Home Page:
    lol that's how passwords are handled in shell.. you will not see anything.. just type and press enter.
     
  10. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    Gogol

    I know that I not see anything... Before this I connected several times to an ubuntu vps via putty ...
    But now there is some problem...
    I tried writing password manually and I tried copy+paste but didn't work...
    acces denied..
     
  11. Gogol

    Gogol Jr. VIP Jr. VIP

    Joined:
    Sep 10, 2010
    Messages:
    4,333
    Likes Received:
    3,823
    Gender:
    Male
    Occupation:
    Dreaming
    Location:
    Pale Blue Dot
    Home Page:
    That could mean that you have not enabled shell access yet (there is an option in the cpanel for that). You cannot connect to cpanel anyway, so better contact the support team as mentioned earlier :)
     
  12. CenTex Hosting

    CenTex Hosting Jr. VIP Jr. VIP

    Joined:
    Nov 8, 2009
    Messages:
    2,410
    Likes Received:
    932
    Gender:
    Male
    Occupation:
    Founder/CEO
    Location:
    Austin, TX
    Home Page:
    You could always reach out to your host to see if they can help out as well.
     
  13. Karwan Jacksi

    Karwan Jacksi Newbie

    Joined:
    Jul 18, 2018
    Messages:
    2
    Likes Received:
    2
    Gender:
    Male


    I just got the same problem you got, but I solved it.

    Just goto /etc/ then edit the wwwacct.conf file and add DEFMOD Xskin to the end of the file. Save and quit.

    My problem got solved by adding this line.
     
    • Thanks Thanks x 1
  14. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    Thanks...
    I still didn't resolve this problem,but I can't find anywhere the /etc folder in WHM
    Where is it located?
     
  15. Karwan Jacksi

    Karwan Jacksi Newbie

    Joined:
    Jul 18, 2018
    Messages:
    2
    Likes Received:
    2
    Gender:
    Male

    You can get the directory using a FTP application such as FileZilla or simply use Putty terminal and locate the file.
     
    • Thanks Thanks x 1
  16. lmarton

    lmarton Regular Member

    Joined:
    Feb 10, 2011
    Messages:
    340
    Likes Received:
    92
    Ok, I inserted the line with vi command in putty but when i use the :wq command to save and quit nothing happens..

    Edit: problem solved...Thank You! It works...