1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Youtube Video not showing in SERPs

Discussion in 'YouTube' started by Jot Angad Singh, Nov 16, 2013.

  1. Jot Angad Singh

    Jot Angad Singh Newbie

    Joined:
    Mar 17, 2012
    Messages:
    19
    Likes Received:
    4
    I uploaded one video to youtube a month back, to promote one affiliate product, the keyword was of medium competition with 18k searches. Anyway I built good quality links from blog networks(which has worked exceptionally in the past), I did social bookmarking for the video, I bought some social signals, video has likes, subscribers and views too. Technically speaking my video has way better links(both in quality & quantity) than other ranking videos. However after one month also, my video is not showing anywhere in SERPs, yes it is indexed, but it not showing up in SERPs, it is weird and I have never experienced this. Can anyone provide possible solution for the same.
     
  2. hardcorebiker

    hardcorebiker Jr. VIP Jr. VIP

    Joined:
    Sep 6, 2011
    Messages:
    1,249
    Likes Received:
    1,045
    Occupation:
    Digital Marketer
    Location:
    Bangkok, Thailand
    That's strange. Can't tell without seeing the video link profile properly. Is the video unique? If its duplicate or copied then that could be that reason for rankings.
     
  3. Beven

    Beven Elite Member

    Joined:
    Aug 30, 2011
    Messages:
    1,810
    Likes Received:
    937
    Location:
    United Kingdom
    It's not jst about quality and quantity. You need to make sure all of these elements come in together to look natural, and they all need to be dripfed.
     
  4. Jot Angad Singh

    Jot Angad Singh Newbie

    Joined:
    Mar 17, 2012
    Messages:
    19
    Likes Received:
    4
    Yes , the video is duplicate, but many duplicate videos are ranking for tough keywords, but still this might be one of the reason.
    Yes all of this were drip feed, I mean the links, can you suggest a possible solution?