1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yoast SEO WP Plugin not working properly?

Discussion in 'Black Hat SEO' started by spectrejoe, Jan 29, 2015.

  1. spectrejoe

    spectrejoe Jr. VIP Jr. VIP

    Joined:
    Sep 25, 2013
    Messages:
    2,105
    Likes Received:
    440
    Home Page:
    I always edit my SEO title like this: "Keyword - Keyword 2"

    Save the posts and all but in google after they get indexed, it shows "Keyword - Domainlink + domaintitle"

    However on some posts the SEO title I chose actually shows up in google, not sure why its working for some and for the others it isnt...
     
  2. Technetik

    Technetik Newbie

    Joined:
    Oct 13, 2014
    Messages:
    22
    Likes Received:
    8
    Home Page:
    right click on your website -> view source.

    Then check your posts title. if its not what you expected, then you have done something wrong with the plugin.
     
  3. spectrejoe

    spectrejoe Jr. VIP Jr. VIP

    Joined:
    Sep 25, 2013
    Messages:
    2,105
    Likes Received:
    440
    Home Page:
    Shows the right title but in google its different... Perhaps its getting instantly indexed since I publish and only then change the title and everything seo related
     
  4. divok

    divok Senior Member

    Joined:
    Jul 21, 2010
    Messages:
    1,067
    Likes Received:
    648
    Location:
    .IN
    it might be your theme. check for any notice in yoast plugin page in admin panel.

    or did you edit those titles after they were indexed ? then it will take some time .