1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WTF? Am I hacked or what?

Discussion in 'White Hat SEO' started by ForeverNever, May 3, 2010.

  1. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    So I'm using Wordpress and Friday I found a theme that I liked, I uploaded it and everything was going smooth. Started putting some content in, then went home and figured I'd keep working on it today (monday).

    When I actually got home on Friday I noticed that all of my content was missing and only the theme was remaining. Today I checked the admin panel and sure enough, all the content is gone.

    wtf is happening?
     
  2. falcommoney

    falcommoney Junior Member

    Joined:
    Jan 11, 2009
    Messages:
    127
    Likes Received:
    62
    Wierd, most of the time "hackers" put some message or a deface when they do something like this...

    I think its something else, especially if you are using the latest wordpress version.
    Im not saying that its impossible to "hack" a website with the newest version, but it makes it harder :p
     
    • Thanks Thanks x 1
  3. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    I don't feel like it's hacked but I can't figure out what the hell else it could be.
     
  4. Deviance

    Deviance Regular Member

    Joined:
    Apr 14, 2009
    Messages:
    205
    Likes Received:
    143
    I also had this happen to me a few months ago, same with you it also was a ''fresh'' blog.

    I guess it was my host doing some work on the servers and using an ''old'' back up.
     
    • Thanks Thanks x 1
  5. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    I hope the problem is that simple. I guess I'll start working again then and see what happens.
     
  6. z3zim4

    z3zim4 Newbie

    Joined:
    Oct 28, 2008
    Messages:
    42
    Likes Received:
    10
    Location:
    Here
    If your using some crap hosting then you host might have deleted it or sumthing...
     
    • Thanks Thanks x 1
  7. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    hostgator
     
  8. cbar126

    cbar126 Junior Member

    Joined:
    Nov 10, 2009
    Messages:
    167
    Likes Received:
    65
    check the template, try to find any encrypted code like base 64 ecode and weird numbes, also if you have any .js files, open with note pad and see if they connect somehow (call home).
     
    • Thanks Thanks x 1
  9. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    There are .js files. How do I tell if they "connect"?
     
  10. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    Ok something is very wrong.

    I just went to publish a post and it instantly deleted itself.

    Damnit I really liked this theme!
     
  11. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    Ok, I changed themes and it is STILL doing it....

    what the hell is happening
     
  12. wannabie

    wannabie Elite Member

    Joined:
    Mar 11, 2009
    Messages:
    3,807
    Likes Received:
    2,954
    Occupation:
    Seo and Marketing Suprisingly
    Location:
    Your bedroom window
    Home Page:
    It may not be the theme, have you had any comments recently?

    I would get firstly scrap everything with the blog and just export your database by using the "tools" under your wp-admin and do everything else from scratch, including deleting your database on your host!

    You will need to open your xml file that you downloaded from your wp-admin and look for anything dodgy i.e hidden codes, squares symbols and once you have deleted all the crap simply import back into your newly installed WP
     
    • Thanks Thanks x 1
  13. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    I got rid of everything and downloaded wp again (may have been using an older version) and am reuploading with a clean theme.
     
  14. Superpower

    Superpower Regular Member

    Joined:
    Mar 27, 2010
    Messages:
    313
    Likes Received:
    31
    Location:
    Just Ahead Of Every Expert
    it must be ya host problem.have u contacted them?
     
  15. metabaron

    metabaron Newbie

    Joined:
    Jan 24, 2010
    Messages:
    25
    Likes Received:
    13
    Yeah, seems like a database problem. Too late to be smart now, but I always make everything on my comp using WAMP (or MAMP if you're a Mac user). That way I have my database an all offline for a backup.

    P.S. WAMP is a virtual server you can run on your PC, so you can install WP on it try things out.

    I'd definitely look into co=relation between your database and hosting.
     
  16. wannabie

    wannabie Elite Member

    Joined:
    Mar 11, 2009
    Messages:
    3,807
    Likes Received:
    2,954
    Occupation:
    Seo and Marketing Suprisingly
    Location:
    Your bedroom window
    Home Page:
    To be honest it just sounds like someone dickhead has injected your database and you will be able to clean that within minutes, its really nothing major just annoying !
     
    • Thanks Thanks x 1
  17. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    Thanks everyone, I think Dansomers was right as when I deleted the database and created a new one and lined everything up, everything is working perfectly again.

    :)
     
  18. wannabie

    wannabie Elite Member

    Joined:
    Mar 11, 2009
    Messages:
    3,807
    Likes Received:
    2,954
    Occupation:
    Seo and Marketing Suprisingly
    Location:
    Your bedroom window
    Home Page:
    Did you have loads of wierd symbols and crappy "hidden" code in your exported xml file?

    Would you mind showing us the theme ?
     
  19. Tim03

    Tim03 Registered Member

    Joined:
    Feb 11, 2010
    Messages:
    58
    Likes Received:
    22
    Hostgator was offline for a certain period, check their twitter account. Maybe that was te problem!
     
  20. rocsk79

    rocsk79 BANNED BANNED

    Joined:
    Sep 23, 2008
    Messages:
    409
    Likes Received:
    123
    I doubt you were hacked. who would go though all the trouble just to erase your content and nothing else.....not even leave a message like "haha" or whatever.

    besides you would know if you were REALLY hacked......you would have never been able to log into your admin panel with you "old" pasword.;)