1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WP Robot kills server other ideas?

Discussion in 'Blogging' started by CottonMouth, May 13, 2010.

  1. CottonMouth

    CottonMouth Newbie

    Joined:
    Nov 30, 2009
    Messages:
    30
    Likes Received:
    7
    I ventured out on the blogging limb for kicks to see if all these success stories were real, and...well....I get the traffic, so that's nice.

    But my CPU runs at 100% constantly and kills the server after about an hour.
    I've narrowed it down to one single plugin - WP Robot.

    Has anyone found a way to cut down on it's resource hogging? I mean, really, my robot pulls only four feeds, and then only once every few hours (like 12-24 hours).
    Simply disabling the plugin makes my site load faster, in 3 seconds vs 15 seconds.

    At any rate, I'm sorta discouraged with WP Robot. Is anyone else watching their CpU usage with their content scraper and seeing good results?
     
  2. CyberWizard

    CyberWizard Junior Member

    Joined:
    Oct 21, 2009
    Messages:
    121
    Likes Received:
    107
    Home Page:
    Are you sure that the issue is with WP-Robot? Pulling that few feeds every 12 hours is not much at all. I don't think that WP-Robot is the cause of your problems. However, you can always try another rss autoposter to test if it it is an issue with the plugin or your server.
     
  3. Googler

    Googler Junior Member

    Joined:
    Apr 15, 2009
    Messages:
    157
    Likes Received:
    190
    Occupation:
    Black Hat Advanced Ninga Trainer
    Location:
    3D World
    Exactlytry to reduce the cron runs and increase the posts during each cron now
     
  4. CottonMouth

    CottonMouth Newbie

    Joined:
    Nov 30, 2009
    Messages:
    30
    Likes Received:
    7
    I think you're right, Cyberwizard. Now without WP-Robot if the blog goes unhit for 10 mins it'll take over a minute to load the front page.
    It seems like WP is hitting the heck out of the PHP engine.
     
  5. trevor1617

    trevor1617 BANNED BANNED

    Joined:
    Nov 12, 2009
    Messages:
    123
    Likes Received:
    64
    maybe try wp-supercache for the times you aren't getting a feed.
     
    • Thanks Thanks x 1
  6. adbox

    adbox Power Member

    Joined:
    May 1, 2009
    Messages:
    658
    Likes Received:
    107
    Home Page:
    WP Robot 3.0 offers cronjob support, you could take it off the psuedo cronjob and setup a real cronjob, and this will probably reduce your usage.

    I've had no server stress complaints from any of my BlogSense users. Your welcome to trial that. I'm doing a 1.00 month trial special for the next 15 days.
     
  7. makingfastcash22

    makingfastcash22 Senior Member

    Joined:
    Feb 15, 2009
    Messages:
    1,152
    Likes Received:
    178
    Home Page:
    Check to see if there is an error log in you directory. Sometimes if there is they can get big. It can also led you to the problem. I use w3 total cache plugin for saving the cpu resources of the server.
     
  8. topsytips

    topsytips Regular Member

    Joined:
    Aug 11, 2008
    Messages:
    334
    Likes Received:
    234
    Occupation:
    Self Employed
    Location:
    UK
    What hosting are you with Cotton Mouth and also what version of WP are you running?

    A few of us seem to be having problems with WP and Hostgator (pages slow to load etc). I have started to wonder though if the problem lies with the latest WP 2.9.2 somehow.
     
  9. randpropz

    randpropz Newbie

    Joined:
    Dec 25, 2009
    Messages:
    13
    Likes Received:
    0
    yes, wp robot also make me suspended!
     
  10. Cyb3rax

    Cyb3rax Newbie

    Joined:
    Apr 28, 2010
    Messages:
    3
    Likes Received:
    1
    I have autoblogged pluging with hostgator baby plan and works fine.
    I`ve added at least 15 feeds and i have another 2 websites on the same HG account.
    No problem for me.Installed super-cache and works even better.
    Is true that those 15 feeds are not some super-feeds that push many articles/hour but if u have only 4 i think it will work well for you.
    Also i use uniquefier plugin to get away with duplicate content and seems this little fucker is working verry well.
    Any thoughts about this plugin?
     
  11. topsytips

    topsytips Regular Member

    Joined:
    Aug 11, 2008
    Messages:
    334
    Likes Received:
    234
    Occupation:
    Self Employed
    Location:
    UK
    What version of WP are you using Cyb3rax?
     
  12. Cyb3rax

    Cyb3rax Newbie

    Joined:
    Apr 28, 2010
    Messages:
    3
    Likes Received:
    1
    i`m using 2.9.2
     
    • Thanks Thanks x 1
  13. nigello

    nigello Newbie

    Joined:
    Dec 15, 2008
    Messages:
    6
    Likes Received:
    0
    i have the same problem -- maxes out my cpu. have narrowed down to wp robot. disabled all plugins and then reactivated one at a time. wp robot climbs like crazy within seconds and maxes out cpu.

    have dedicated server and plenty of resources.

    also, wish there were a way to have one wp robot that would run multiple wp sites, rather than having to install wp robot on each site.
     
  14. G0D0VERY0U

    G0D0VERY0U Regular Member

    Joined:
    Apr 6, 2010
    Messages:
    439
    Likes Received:
    282
    Are you guys seeing this problem just with the new 3.0 update? I'm using 2.x and don't have these issues - but it makes me scared to upgrade. All of my online money is based on a handful of Wiredtree servers and I can't afford to have a disconnect. It wouldn't hurt me financially, but it would be a huge PITA.
     
  15. CottonMouth

    CottonMouth Newbie

    Joined:
    Nov 30, 2009
    Messages:
    30
    Likes Received:
    7
    Here's the culmination of my WP-Robot usage
    PHP Fatal error: Maximum execution time of 300 seconds exceeded in C:\webs\yourwebs\someweb.com\wp-includes\class-IXR.php on line 571

    Increasing the timeout just lets it hang after a longer pause.

    Memory usage rolls way up past 2 gb then it just dies or freezes the server. Infinite spool anyone :)

    So yeah, WP Robot doesn't really work for me.