1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WP-robot bug fix

Discussion in 'Black Hat SEO Tools' started by dima054, Sep 17, 2011.

  1. dima054

    dima054 Regular Member

    Joined:
    Jan 19, 2011
    Messages:
    447
    Likes Received:
    154
    Hopefully it's useful and i post it in a right place.
    You probably noticed that some of your wp-robot posts contain shit like "&#thirteen", "&#13", "&#nsbp", right?
    The solution is, go to wp-robot dir/modules. Open the Article.php
    Inside almost at the end there are some lines of
    Code:
    $post = str_replace
    Find last of those and add
    Code:
                $post = str_replace(' ', '', $post);
                $post = str_replace('&#13', '', $post);
                $post = str_replace('&#thirteen;', '', $post);
                $post = str_replace('&#thirteen', '', $post);
                $post = str_replace(' ', '', $post);
                $post = str_replace('&nbsp', '', $post);
                $post = str_replace(']]>;', '', $post);
                $post = str_replace(']]>', '', $post);
    Then save the file and upload it to the hosting. For fixing existing posts, run an SQL query, but not sure its safe as i never tried. This file editing thingie works OK on wprobot 3.2 and 3.5
     
    • Thanks Thanks x 1
  2. eaglejv

    eaglejv Newbie

    Joined:
    Nov 10, 2010
    Messages:
    8
    Likes Received:
    2
    thanks for the tips.. I will aplly on my WP-robot
     
  3. dima054

    dima054 Regular Member

    Joined:
    Jan 19, 2011
    Messages:
    447
    Likes Received:
    154
    Do it only if you see those wierd things in your posts...