1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wp menu load very slow

Discussion in 'Blogging' started by MariosElGreco, Feb 4, 2017.

  1. MariosElGreco

    MariosElGreco Regular Member

    Joined:
    May 31, 2014
    Messages:
    261
    Likes Received:
    8
    Gender:
    Male
    Occupation:
    http://eas-seo.com
    Location:
    Greece
    Home Page:
    I have multiple subcategories and is very hard to load them , any conclusion ?
    Its on wordpress, and i want to know if its from hosting or from wordpress the problem and how if i can overcome to it.
    http://articles.eas-seo.com/
     
  2. blogzandstuff

    blogzandstuff Elite Member

    Joined:
    Jan 1, 2015
    Messages:
    5,229
    Likes Received:
    2,413
    Occupation:
    blog creator
    Location:
    UK
    Loads fine on my mobile from the uk
     
  3. MariosElGreco

    MariosElGreco Regular Member

    Joined:
    May 31, 2014
    Messages:
    261
    Likes Received:
    8
    Gender:
    Male
    Occupation:
    http://eas-seo.com
    Location:
    Greece
    Home Page:
    check this video .
     
  4. umerjutt00

    umerjutt00 Jr. VIP Jr. VIP

    Joined:
    Oct 28, 2011
    Messages:
    3,825
    Likes Received:
    2,066
    Occupation:
    Ninja
  5. MariosElGreco

    MariosElGreco Regular Member

    Joined:
    May 31, 2014
    Messages:
    261
    Likes Received:
    8
    Gender:
    Male
    Occupation:
    http://eas-seo.com
    Location:
    Greece
    Home Page:
    if it host , what should i increase ?
     
  6. blogzandstuff

    blogzandstuff Elite Member

    Joined:
    Jan 1, 2015
    Messages:
    5,229
    Likes Received:
    2,413
    Occupation:
    blog creator
    Location:
    UK
    It seems to be your internet connection, works fine here
     
  7. terrycody

    terrycody Supreme Member

    Joined:
    Sep 29, 2012
    Messages:
    1,416
    Likes Received:
    386
    Occupation:
    marketer
    Location:
    Hell
    possibilities:


    1) your hosting sucks

    2) your theme contain Google fonts and your IP is relatively slow to access it via Greece country if I am right

    I use US VPN to access your site and no problem, I think maybe your Google fonts problem or whatever no idea then lol. When you keep loading on page, look left bottom corner of your browser and see which step it lagged there, you may find some clues.
     
  8. MariosElGreco

    MariosElGreco Regular Member

    Joined:
    May 31, 2014
    Messages:
    261
    Likes Received:
    8
    Gender:
    Male
    Occupation:
    http://eas-seo.com
    Location:
    Greece
    Home Page:
    it start happens when i add 100more subcategories , before that it worked fine .
    So google fonts its fine , but i check browse via other ip's outside Greece.