WP Blog Problem

Discussion in 'Blogging' started by Jean Luc Jean, Jul 6, 2011.

  1. Jean Luc Jean

    Jean Luc Jean Registered Member

    Joined:
    Oct 28, 2010
    Messages:
    76
    Likes Received:
    32
    Occupation:
    Internet Entrepreneur
    Location:
    NJ
    While I was upgrading to the new version, something happened to my site and now all I get is the following errors whenever I try to go to the site or login to the admin area:

    Warning: require_once(/home/rheumato/public_html/wp-includes/class-json.php) [function.require-once]: failed to open stream: No such file or directory in /home/rheumato/public_html/wp-content/plugins/tweet-this/tweet-this.php on line 145

    Fatal error: require_once() [function.require]: Failed opening required '/home/rheumato/public_html/wp-includes/class-json.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/rheumato/public_html/wp-content/plugins/tweet-this/tweet-this.php on line 145


    I already deleted Tweet-this plugin from the site but I still get the same error. Does anyone know how to fix this?
     
  2. wickedguy

    wickedguy Supreme Member

    Joined:
    Jul 22, 2009
    Messages:
    1,406
    Likes Received:
    1,382
    Location:
    BHW--> South Africa
    Home Page:
    it simply means that class-json.php does not exist. You can upload it via ftp or you can simply delete the tweet-this folder via ftp
     
  3. Jean Luc Jean

    Jean Luc Jean Registered Member

    Joined:
    Oct 28, 2010
    Messages:
    76
    Likes Received:
    32
    Occupation:
    Internet Entrepreneur
    Location:
    NJ

    I already deleted the tweet-this folder and the class-json.php file IS there but I am still getting the same error.
     
  4. wickedguy

    wickedguy Supreme Member

    Joined:
    Jul 22, 2009
    Messages:
    1,406
    Likes Received:
    1,382
    Location:
    BHW--> South Africa
    Home Page:
    then clear your wp cache
     
  5. Jean Luc Jean

    Jean Luc Jean Registered Member

    Joined:
    Oct 28, 2010
    Messages:
    76
    Likes Received:
    32
    Occupation:
    Internet Entrepreneur
    Location:
    NJ

    How do you clear WP cache when I cant even log into it?
    I really dont get this. It looks like a simple problem, like you said above, but for some reason, I cannot log into it or anything without these same errors coming up.
    I even tried to re-install all the WP files and still get the same exact thing. Im upset now because this is a site I spent a lot of time on lately and started driving traffic
    to it and now I cant even recover it. The domain is rheumatoidarthritis-symptoms.com
     
    Last edited: Jul 6, 2011
  6. Jean Luc Jean

    Jean Luc Jean Registered Member

    Joined:
    Oct 28, 2010
    Messages:
    76
    Likes Received:
    32
    Occupation:
    Internet Entrepreneur
    Location:
    NJ
    Problem was solved by my hosting company. They went into my server, moved the 'tweet-this' plugin up one directory, out of the plugin path, and the errors cleared.
     
    • Thanks Thanks x 1