1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Working Facebook Unfollow for Imacros Script

Discussion in 'Social Networking Sites' started by miana80, Dec 30, 2013.

  1. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    hi all, i would like to share my personal imacros script to unfollow people,( not pages ) on Facebook
    i mean this works for me, i guess it will for you.

    log in to FB
    instead the xxxxxxxxx, put your FB's url


    VERSION BUILD=8601111 RECORDER=FX
    TAB T=1
    URL GOTO=hXXXs://XXX.facebook.XXX/XXXXXXXXXXXXXXXXXXXXXXXXXXXX/following
    TAG POS=1 TYPE=SPAN ATTR=TXT:people
    WAIT SECONDS=2
    TAG POS=1 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=4
    TAG POS=2 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=3
    TAG POS=3 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=5
    TAG POS=4 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=3
    TAG POS=5 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=2
    TAG POS=6 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=4
    TAG POS=7 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=15


    max to how much as you need, and press play loop.

    see ya



    P.S sometimes appens that the people to unfollow runs out, and the script wil end with error,
    it's ok, you'll have only to wait the page to came back to normal, and run it again
     
    • Thanks Thanks x 2
    Last edited: Dec 30, 2013
  2. EddieC123

    EddieC123 Regular Member

    Joined:
    Jan 8, 2013
    Messages:
    346
    Likes Received:
    180
    Should put at least a 2 second wait between unfollows, won't be too long before you get a 'slow down' message from Facebook otherwise.
     
  3. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    sure, i'm gonna edit the script right now.
    thank you for the tip :)
     
  4. EddieC123

    EddieC123 Regular Member

    Joined:
    Jan 8, 2013
    Messages:
    346
    Likes Received:
    180
    Best to stay safe & make the wait time random as well - some at 2 secs, some at 3, some at 4.
     
  5. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    ok, no problems at all.
    lots of people will be gratefull if we build a safe script to unfollows,
    because the imacros on the web are useless.
    TY
     
  6. BuritoBandito

    BuritoBandito Registered Member

    Joined:
    Jan 8, 2014
    Messages:
    68
    Likes Received:
    9
    hey im getting an error on line 4: RuntimeError: element A specified by TXT:people was not found, line: 4 (Error code: -921)

    Its this line thats giving me an error: TAG POS=1 TYPE=SPAN ATTR=TXT:people

    Can you help?
     
  7. BuritoBandito

    BuritoBandito Registered Member

    Joined:
    Jan 8, 2014
    Messages:
    68
    Likes Received:
    9
    hey im getting an error on line 4: RuntimeError: element A specified by TXT:people was not found, line: 4 (Error code: -921)

    Its this line thats giving me an error: TAG POS=1 TYPE=SPAN ATTR=TXT:people

    Can you help?
     
  8. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    facebook made some change to that page, i'm working on it.
    i'll post soon the new script
     
  9. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    Ok, change this old line "TAG POS=1 TYPE=SPAN ATTR=TXT:people"

    with this new one "TAG POS=1 TYPE=DIV ATTR=TXT:people"

    and it'll work like a charm.

    BTW, you can add all the lines u need till 400 by only changing the number in a progressive order

    example;
    TAG POS=201 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=5
    TAG POS=202 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=3
    TAG POS=203 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=2
    TAG POS=204 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=4
    TAG POS=205 TYPE=A ATTR=TXT:Following

    enjoy and sorry for my crappy english
     
  10. aymanax

    aymanax Newbie

    Joined:
    Apr 28, 2013
    Messages:
    5
    Likes Received:
    0
    I keep getting this message: "RuntimeError: element DIV specified by TXT:people was not found, line: 4 (Error code: -921)"

    EDIT: I removed this line: "TAG POS=1 TYPE=DIV ATTR=TXT:people" from script and works fine!Thank you OP!
     
    Last edited: Jan 18, 2014
  11. krismania

    krismania Junior Member

    Joined:
    Aug 29, 2013
    Messages:
    165
    Likes Received:
    19
    Thanks for the script, I'll put that to good use now.
     
  12. dropshippa

    dropshippa Regular Member

    Joined:
    Oct 27, 2013
    Messages:
    463
    Likes Received:
    53
    Location:
    Antarctica
    thanks for sharing
     
  13. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    facebook made some change......like always :(

    anyway the script working is:

    VERSION BUILD=8601111 RECORDER=FX
    TAB T=1
    URL GOTO=hXXXs://XXX.facebook.XXX/XXXXXXXXXXXXXXXXXXXXXXXXXXXX/following
    WAIT SECONDS=2
    TAG POS=1 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=4
    TAG POS=2 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=3
    TAG POS=3 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=5
    TAG POS=4 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=3
    TAG POS=5 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=2
    TAG POS=6 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=4
    TAG POS=7 TYPE=A ATTR=TXT:Following
    WAIT SECONDS=15





    enjoy :)
     
    • Thanks Thanks x 2
  14. DJQB031

    DJQB031 Newbie

    Joined:
    Feb 26, 2013
    Messages:
    4
    Likes Received:
    0
    this last script is working, i am running as .iim without problems. thanks
     
  15. miana80

    miana80 Newbie

    Joined:
    Dec 1, 2013
    Messages:
    7
    Likes Received:
    4
    you're welcome :)
     
  16. sigmaphi

    sigmaphi Registered Member

    Joined:
    Mar 31, 2012
    Messages:
    81
    Likes Received:
    20
    Home Page:
    Thanks a lot it working , tried it on chrome and it did not work , but when i did on firefox it did 100% , :)