1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wordpressblogs showing white/blank?

Discussion in 'BlackHat Lounge' started by louisp2500, Feb 2, 2013.

  1. louisp2500

    louisp2500 Regular Member

    Joined:
    Feb 24, 2011
    Messages:
    378
    Likes Received:
    58
    Hey suddenly my wordpress sites are showing white/blank when entering? my HTML sites are fine, i have reinstalled wordpress and it worked, and then it was back to normal, suddenly it only showed up in google chrome and not explorer, and now it´s not working AGAIN, has anyone seen this ignoring problem before???? Heeelp
     
  2. geekmom

    geekmom Newbie

    Joined:
    Jan 31, 2013
    Messages:
    8
    Likes Received:
    2
    Occupation:
    Internet Marketing/Social Networking Queen
    Location:
    USA
    Home Page:
    If your server is setup so that server error messages do not display on your page then it will show as blank. It could be a plugin or even a graphic that isn't loading. If it happened to me I would check my server log files for any errors and then disable plugins and add them one-by-one if there was no indication of what might be causing it. Did you add anything new lately? That might be the first culprit.
     
  3. louisp2500

    louisp2500 Regular Member

    Joined:
    Feb 24, 2011
    Messages:
    378
    Likes Received:
    58
    no i havent added anything my virus programme says that i have something like mass injection??? what to do what to do, but my friends can´t see my sites either, but my HTML sites are working fine on same server
     
  4. geekmom

    geekmom Newbie

    Joined:
    Jan 31, 2013
    Messages:
    8
    Likes Received:
    2
    Occupation:
    Internet Marketing/Social Networking Queen
    Location:
    USA
    Home Page:
    code could have been injected into your sql database or your wp settings file. i'd compare your settings file with an original and if there are any changes other than the ones you made then you should remove the changes or make a new copy of the wordpress settings. also, update wordpress itself and any plugins you have with the latest versions. do you back up your database often? then restore one that worked before this happened. make sure ALL your files and directories can only be written by the server. do not just leave them all at 777 permissions. since i can't post links yet i can't show you any examples, but you can try a search on google for wordpress mass sql injection and that should give you more ideas.

    another idea... change the table prefix in the wp settings file to something other than wp_ this makes it more difficult for them to change your tables or inject code.
     
  5. louisp2500

    louisp2500 Regular Member

    Joined:
    Feb 24, 2011
    Messages:
    378
    Likes Received:
    58
    is it the config file you are talking about? leaving it not at 77 permissions? it must be hacked, cause i uploaded wordpress again and it worked, and then it didnt worked, and then it worked in chrome, and not in explorer!! arghhhhhhh
     
  6. louisp2500

    louisp2500 Regular Member

    Joined:
    Feb 24, 2011
    Messages:
    378
    Likes Received:
    58
    i have just uploaded wordpress again, and now the site is working, so it must be a virus, but how the hell do i remove this? it must be on server to since my friends either can see my sites when they going down?