WordPress Theme Error

Vento

Registered Member
Nov 23, 2009
64
29
Anyone knows how to fix this?


Code:
[B]Warning[/B]:  Cannot modify header information - headers already sent  by (output started at  /hermes/web10/b639/moo.lithiummedia/adaptive-media/wp-content/themes/Jenks/functions.php:183)  in [B]/hermes/web10/b639/moo.lithiummedia/adaptive-media/wp-includes/pluggable.php[/B] on line [B]890[/B]
Just installed a theme, configured it, was working fine, then just came out of nowhere. It shows up on the wp-admin page, and some people are saying it shows up on the actual site aswell :confused:
 
what is the content on themes/Jenks/functions.php between line 180 and line 190?
 
Thanks for replying origin.

It's:

PHP:
    add_action('it_footer', 'print_tracking');
?>

<?php

add_action('admin_menu', 'mt_add_pages');

function mt_add_pages() {
    add_links_page(__('WordPress Link','menu-test'), __('WordPress Link','menu-test'), 'manage_options', 'wplink', 'mt_links_page');

    add_management_page( __('Akismet Counter','menu-test'), __('Akismet Counter','menu-test'), 'manage_options', 'akister', 'mt_tools_page');
 
And which one is line 183?
This usually happen when there is an php echo instruction came up before the header. The workaround is by adding:
<?php ob_start(); ?>
...
<?php ob_flush(); ?> // at the end of the function.
 
Line 183 is: <?php

That's it.

Could I send you the functions.php file through PM? And you can edit it? I'm not that experienced with PHP.

Thanks :)
 
The first thing i would have tried was to re upload your themes header.php file and just replace the existing one this normally works to put things right and also chmod the functions.php to 777
 
Last edited:
Back
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features and essential functions on BlackHatWorld and other forums. These functions are unrelated to ads, such as internal links and images. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock