1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wordpress error: Incorrect integer value: '' for column 'id' at row 1.

Discussion in 'Blogging' started by Powelly, Feb 2, 2012.

  1. Powelly

    Powelly Regular Member

    Joined:
    Jan 1, 2010
    Messages:
    200
    Likes Received:
    29
    Hi there,

    We are having trouble with some of our blogs.

    We setup Wordpress fine, however when displayed in the serp results it shows the meta description as 'Incorrect integer value: '' for column 'id' at row 1.'

    Anyone else had similar experiences or know how to solve?
     
  2. Pekton

    Pekton Regular Member

    Joined:
    Nov 28, 2009
    Messages:
    250
    Likes Received:
    104
    Location:
    upstate ny
    are you running any plugins that are generating the meta description for you?
     
  3. Powelly

    Powelly Regular Member

    Joined:
    Jan 1, 2010
    Messages:
    200
    Likes Received:
    29
    Nope.
     
  4. Pekton

    Pekton Regular Member

    Joined:
    Nov 28, 2009
    Messages:
    250
    Likes Received:
    104
    Location:
    upstate ny
    the error itself is caused by either the theme or a plugin trying to send incorrectly formatted data to your mysql database. The database is running in strict mode so it throws up an error.

    If you cannot see that error when you view the page, the page's html source or while in wp backend then I would say the error has been fixed by an update. If you do see the error your self it should give you a longer description so you can track down what is sending the wrong data.

    The trouble with your google results is that the googlebot crawled that page while the error was on display, read it as the first text on the page and so used it for its snippet.

    If you are no longer seeing the error on the site then you just need to get google to recrawl those pages affected
     
  5. Powelly

    Powelly Regular Member

    Joined:
    Jan 1, 2010
    Messages:
    200
    Likes Received:
    29
    I tried disabling all plugins, and still the same load of errors in the admin dashboard on wordpress:
    Deprecated: Assigning the return value of new by reference is deprecated in D:\Sites\sitename\public_html\wp-includes\class-simplepie.php on line 738

    etc
     
  6. paulcarter97

    paulcarter97 Regular Member

    Joined:
    Nov 27, 2011
    Messages:
    392
    Likes Received:
    37
    Probably your plugin is messed up. Remove all of your plugin
     
  7. adbox

    adbox Power Member

    Joined:
    May 1, 2009
    Messages:
    658
    Likes Received:
    107
    Home Page:
    Am working with this. I've never seen the error before except now on a server running 'mysqlnd 5.0.7-dev - 091210 - $Revision: 300533 ' and hosted on a 'Windows NT H1784211 6.1 build 7601' server. I bet there is a strict mode in affect. To counter it I've modified all instances of INSERT queries that include the autoincriment id field but left the value blank... which normally we can do.