1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What am I doing wrong?

Discussion in 'White Hat SEO' started by grifter1, Jun 18, 2011.

  1. grifter1

    grifter1 Newbie

    Joined:
    Jun 17, 2011
    Messages:
    16
    Likes Received:
    0
    I have a WordPress blog ,about 3 months old. Google indexed it pretty quick and then a week ago I noticed my homepage is no longer indexed (posts are however.)

    I have a magazine type layout with post excerpts from top content showing on the front page - I'm starting to think this may be bad for my ranking (although it looks really good.) My blog is pretty much a niche site, but not narrowed down - it's a website for parents with several sub-topics.

    When I search for my main keyword in google I show up on the first page about 8th or 9th on the list, however in this result it says "you shared this" I'm not sure what that mean. Is it just showing up there for me due to being signed in to my Google account, or am I actually ranked for that keyword?
    I do have a PR of 0 which I suspect is normal for a new blog 3 months old.
    I really want to get this up however seeing as though many advertisers have contacted me wanting to place links on my site and work with me, but the lack of PR has ruined alot.

    Is there anything anyone could suggest to get my PR up
     
  2. KraftyKyle

    KraftyKyle Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Aug 13, 2008
    Messages:
    1,941
    Likes Received:
    4,609
    Gender:
    Male
    Location:
    Unknown
    If you PM me your link I'll take a look at it and let you know.
     
  3. grifter1

    grifter1 Newbie

    Joined:
    Jun 17, 2011
    Messages:
    16
    Likes Received:
    0
    I have to post more to be able to PM! I just joined the board
     
  4. grifter1

    grifter1 Newbie

    Joined:
    Jun 17, 2011
    Messages:
    16
    Likes Received:
    0
    I just PM'd you.