1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird Issue with Bing/Yahoo

Discussion in 'White Hat SEO' started by fastlaner, Nov 2, 2012.

  1. fastlaner

    fastlaner Newbie

    Joined:
    Mar 15, 2012
    Messages:
    38
    Likes Received:
    6
    Hi guys,

    Ive been having an issue with bing/yahoo lately, my pages just don't seem to get indexed beyond the initial domain name, my pages have keyword titles as the file name so should rank higher, I'm trying to rank for town/city names and do local SEO for clients.

    I've only submitted a HTML site map as the site is static html but I am now submitting an XML sitemap to see if that works.

    Anyone experience this before and know a solution?

    Thanks in advance.
     
  2. Endire

    Endire Elite Member Premium Member

    Joined:
    Mar 27, 2012
    Messages:
    1,756
    Likes Received:
    1,061
    Gender:
    Male
    • Thanks Thanks x 1
  3. fastlaner

    fastlaner Newbie

    Joined:
    Mar 15, 2012
    Messages:
    38
    Likes Received:
    6
    Hi Shawn,

    Yes the site is static and has meta tags, I have loaded 5 keywords into here so not stuffing it, I used to get really good rankings from bing and yahoo but it seems bing just doesn't like indexing my deep pages or even my site sometimes, the strange thing is that yahoo has indexed both of my clients websites but again no deep pages.

    I will try removing the meta tags and report back, thanks for the heads up.
     
  4. oskedi01

    oskedi01 Regular Member

    Joined:
    Oct 6, 2011
    Messages:
    200
    Likes Received:
    72
    Location:
    Sweden
    Home Page:
    Did you add your sitemaps to bing and yahoos webmaster tools? If i remember right they got these just as google webmaster. Not 100% sure but you should look it up :)
     
  5. fastlaner

    fastlaner Newbie

    Joined:
    Mar 15, 2012
    Messages:
    38
    Likes Received:
    6
    There is also some content that I basically copied from the main page and changed the keywords for, this are locational pages so something like /accountant-cityname.html - do you think these could be causing the issue aswell?