1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

We have started losing links

Discussion in 'White Hat SEO' started by Mister A, Sep 29, 2012.

  1. Mister A

    Mister A Registered Member

    Joined:
    Dec 31, 2011
    Messages:
    70
    Likes Received:
    3
    Complete Noob here.
    We had several backlinks that I think were removed,maybe with a group of 3 guys posting our site back links to it.We overdid it.
    We had yahoo,reddit,huffington post,and an adobe.
    Being so new I really do not know the best way to get back links,and keep them active.
    Any good info on this would be awesome.
    Thanks
     
  2. download

    download Jr. VIP Jr. VIP Premium Member

    Joined:
    May 4, 2010
    Messages:
    1,271
    Likes Received:
    712
    Location:
    USA
    I'm having a slightly difficult time trying to understand what you mean here.
    Are you saying that backlinks you created/paid for are being removed? And that these backlinks were on the yahoo, reddit, HP, and adobe websites?
     
  3. Mister A

    Mister A Registered Member

    Joined:
    Dec 31, 2011
    Messages:
    70
    Likes Received:
    3
    These were feedback on there blogs.
    We had 2 for about a year,but I think that with all the extra posts to there forums we may have been labeled spam.
    We had a yahoo answers for over a year that just disappeared.
     
  4. Mister A

    Mister A Registered Member

    Joined:
    Dec 31, 2011
    Messages:
    70
    Likes Received:
    3
    Never paid for them,they were placed by members of our forum.
     
  5. JTKirk

    JTKirk Newbie

    Joined:
    Sep 27, 2012
    Messages:
    16
    Likes Received:
    1
    Im very curious about the cause of this too. Hopefully you get an answer soon. Good luck!