1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Warning] Are You Using Wordpress 2.8.4 and Having Difficulties to Get Your Site Indexed?

Discussion in 'White Hat SEO' started by Ninjutsu, Oct 17, 2009.

  1. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    Is has come to my attention that ALL of my sites that are installed with Wordpress 2.8.4 are not indexed by Google after days....weeks...and months...

    I never had any problem indexing my websites within HOURS. So it must be some setting in wordpress that is causing this problem.

    I went to dig further for the truth, and to my SHOCKING... new wordpress 2.8.4 installs are set as no-index as default.

    If you're using Wordpress 2.8.4 and having problems to get your site indexed, you might want to check your Privacy Setting>>Blog Visibility as shown in this screen shot:


    [​IMG]

    /facepalm

    Change the damn setting to allow google to index your site...(I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers)

    I know it sucks to build hundreds/thousands of links to your wordpress blogs to get your site indexed with that setting. :)

    If you're not using wordpress and want to get your site indexed within hours, check this thread:

    Code:
    http://www.blackhatworld.com/blackhat-seo/white-hat-seo/92108-google-indexing-backlinks-really-quick.html?highlight=index
    Good luck.

    Hope this helps.
     
    • Thanks Thanks x 17
  2. sidddd

    sidddd Power Member

    Joined:
    May 15, 2008
    Messages:
    749
    Likes Received:
    460
    Isn't this message displayed for all the wordpress installs? You must have checked that while installing.. it's not a default option for sure.
     
  3. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    It is set to default if you're using Fantastico to install wordpress.
     
  4. TheSlugClub

    TheSlugClub BANNED BANNED

    Joined:
    Apr 7, 2009
    Messages:
    269
    Likes Received:
    115
    yea, and search for the huge pinglist here and use that too. works perfect for me. the spiders come storming me in about a minute after i make any post on any of my blogs
     
  5. nothingnothing

    nothingnothing Jr. VIP Jr. VIP Premium Member

    Joined:
    Jan 20, 2008
    Messages:
    275
    Likes Received:
    236
    Yup it is the default setting in 2.8.4. I realized that after 2 days when my statpress showed no spider movement.
     
  6. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    I can see that there are already few threads here talking about why google is not indexing their website after weeks or months. This is probably the reason.
     
  7. mahan_eesh

    mahan_eesh Regular Member

    Joined:
    Jul 7, 2008
    Messages:
    411
    Likes Received:
    806
    Occupation:
    FULL TIME IM
    Location:
    From the land of opportunities.
    I didnt knew about this. will check it now to see what's my blog's status. lol [:)]
     
  8. pinoyvid

    pinoyvid Junior Member

    Joined:
    Jun 12, 2008
    Messages:
    190
    Likes Received:
    26
    WOW.

    I'm having a problem with one of site and this is the reason. Thanks man.
     
  9. hunar

    hunar Regular Member

    Joined:
    Jan 1, 2009
    Messages:
    479
    Likes Received:
    178
    Location:
    Minnesota
    I found this out a while ago after having a lot of trouble getting my sites indexed. Actually I didn't find it but a friend of mine did. My sites were still getting indexed but just no cache. I still have a hard time getting indexed now (yes I always make sure that's checked) I just got a site indexed after making it 1 month and half ago lol.
     
  10. Malcolm Keo

    Malcolm Keo Newbie

    Joined:
    Jan 19, 2008
    Messages:
    15
    Likes Received:
    10
    Thanks Ninjutsu, the default really set to "I would like to block search engines, but allow normal visitors". Believe that is the problem
     
  11. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    No problem, guys :) Glad it helped some of you here.
     
  12. emilex

    emilex Regular Member

    Joined:
    Jul 22, 2009
    Messages:
    231
    Likes Received:
    85
    Occupation:
    Playing Football
    Location:
    Europe
    I have checked and it is ok in my version...
     
  13. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    I heard that the no-index default setting only happens if you install wordpress via fantisco.

    If you install wordpress manually, you shouldn't have any problem there.
     
  14. Scripteen

    Scripteen Elite Member

    Joined:
    Sep 19, 2009
    Messages:
    1,811
    Likes Received:
    1,918
    Home Page:
    Thanks for the heads up, this happens in fresh installs not upgrades though.

    Now sure why fantastico did this. stupid developer. not one more setting to change when installing a new blog.
     
  15. sidddd

    sidddd Power Member

    Joined:
    May 15, 2008
    Messages:
    749
    Likes Received:
    460
    Cool.. I install manually always.. thanks for letting us know about this. Sure, that sucks :p
     
  16. topsytips

    topsytips Regular Member

    Joined:
    Aug 11, 2008
    Messages:
    334
    Likes Received:
    234
    Occupation:
    Self Employed
    Location:
    UK
    Correct...I only found out by accident. I usually alter mine once I have sufficient content on the blog to "go live."

    I actually found the quickest way to get indexed was by submitting the site (including sub domains) to cubestats which was a tip shared by BHW member Antx16 in this thread.

     
  17. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    that's the link that I shared in the first post. :)

    It works and has been working well for me too.
     
  18. topsytips

    topsytips Regular Member

    Joined:
    Aug 11, 2008
    Messages:
    334
    Likes Received:
    234
    Occupation:
    Self Employed
    Location:
    UK
    lol Sorry Ninjutsu...I skipped over that bit!! :p

    Best of luck with your blog(s)!! ;)
     
    • Thanks Thanks x 1
  19. Ninjutsu

    Ninjutsu Regular Member

    Joined:
    Aug 30, 2009
    Messages:
    254
    Likes Received:
    144
    Location:
    Anywhere. Anytime.
    No problem. Same to you, good luck and make more moooonies ;)
     
    • Thanks Thanks x 1
  20. gregdickson

    gregdickson Registered Member

    Joined:
    Feb 15, 2008
    Messages:
    50
    Likes Received:
    97
    Don't I feel like a fool I have been trying to sort that out for a week now. Cheers bro