1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

uBot Help?

Discussion in 'Black Hat SEO Tools' started by meatro, Nov 8, 2011.

  1. meatro

    meatro BANNED BANNED

    Joined:
    Nov 21, 2009
    Messages:
    568
    Likes Received:
    997
    I'm trying to get uBot to navigate to a relative URL... Anybody know how to do this?

    The starting URLs are "site.com/forums/member.php?u=12345" I want it to navigate to "/index.php"

    When I try to do this, it navigates to "http:///index.php" or "http://index.php"

    I have one or two other questions, but until then, I'm stuck on this step. I think this will be a pretty cool little bot that I'll share for free on BHW. :)
     
  2. ericsson

    ericsson Elite Member Premium Member

    Joined:
    Apr 25, 2009
    Messages:
    2,642
    Likes Received:
    8,132
    Occupation:
    www
    Location:
    Swe
    Home Page:
    Might ask SweTech here on bhw.. he might give u that help that u need. GL!
     
    • Thanks Thanks x 1
  3. acadian60

    acadian60 Registered Member

    Joined:
    Nov 3, 2010
    Messages:
    60
    Likes Received:
    14
    Try ../../index.php
     
    • Thanks Thanks x 1
  4. meatro

    meatro BANNED BANNED

    Joined:
    Nov 21, 2009
    Messages:
    568
    Likes Received:
    997
    That just does the same thing as sending it to a relative URL.. (http:///index.php)
     
  5. wowhaxor

    wowhaxor Executive VIP Premium Member

    Joined:
    Apr 28, 2007
    Messages:
    2,021
    Likes Received:
    3,353
    Location:
    ?¿?
    Home Page:
    Just type in the whole link you want it to navigate to? Or have it click a link to the main page on the page you're on? Or are you trying to make 1 process for a bunch of sites so you need to do it this way?
     
    • Thanks Thanks x 1
  6. meatro

    meatro BANNED BANNED

    Joined:
    Nov 21, 2009
    Messages:
    568
    Likes Received:
    997
    Just a short intro to what I'm doing, if anybody wants to chip in...

    Basically, I'm "tweaking" (screw you, Jobs) PHPBuilt's idea of http://www.blackhatworld.com/blackhat-seo/black-hat-seo/365115-free-all-page-ranking-you-want-then-some.html. I use XRumer to build profile back links and I'm very intrigued with his method.

    So here's what the bot does... So far:

    1.) User is prompted to load a profiles list.. Just a text file containing 1 profile URL per line.
    2.) User is prompted to load a proxies list. Standard 127.0.0.1:1234 format. 1 per line.
    3.) User is prompted for username:password for profiles... !!!
    4.) Bot sets Google Chrome as the user agent and sets the first proxy.
    5.) Bot navigates to the first URL and logs in using credentials provided.
    6.) Bot waits 7 seconds to be forwarded.
    7.) Bot repeats steps 4-6.

    That's it so far. After this, I want it to load the index page of the forums, which is why I need to load a relative URL. I've tried having it click the home button, but there's so many variations between forums for this (home, forum, image link, etc) that it's not reliable. Once on the homepage, I want it to scrape all "member.php" links and load them as the logged in user. Then move on to the next forum.

    A couple of the issues I'm having..

    1.) Loading a relative URL to go from the profile page to the forum's homepage.
    2.) Reading a specific string from a text file and using that as a variable... So the profiles don't all have to be the same username:password. Ideally, I'd like it to be able to "read" the XRumer "registered accounts.txt" file and basically go on its own.

    Sorry.. This is my first day using uBot. :) I've been watching/reading tutorials all day, but their forums are useless. Instead of actually answering questions, those people just post the bots that do what people are asking. Worthless. HOW THE FUCK DID YOU DO IT??

    Here's what I have so far: http://www.mediafire.com/?lnoljkfu7h7ly52 (uBot project file)

    http://www.mediafire.com/?65ylcywsvts84s5 Bot EXE File
    Code:
    http://www.virustotal.com/file-scan/report.html?id=a7532b5ab41378a8d81bf75886a72f8187530232fe29c305108c6f133912f167-1320776810
    
    File name: abc.exe
    Submission date: 2011-11-08 18:26:50 (UTC)
    Current status: finished
    Result: 1/ 43 (2.3%)
     
    Last edited: Nov 8, 2011
  7. wowhaxor

    wowhaxor Executive VIP Premium Member

    Joined:
    Apr 28, 2007
    Messages:
    2,021
    Likes Received:
    3,353
    Location:
    ?¿?
    Home Page:
    Well, I think most of the forums will have some line in common for their URL, use a wildcard (you just put a * on each side of it, deleting the rest and select "wildcard" instead of exact match) and you should be able to get it (like they should all have index.php or something in there, dunno you'll have to take a look yourself.
     
    • Thanks Thanks x 1