1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange 404 Crawl Errors in Webmaster Tools

Discussion in 'White Hat SEO' started by keryanJames, Feb 26, 2014.

  1. keryanJames

    keryanJames Registered Member

    Joined:
    Jul 24, 2013
    Messages:
    93
    Likes Received:
    18
    Good evening!

    One week ago I noticed that the 404 crawl errors shown in Webmaster tools have increased a lot. But they are very strange.

    Let's say my website is named www.strangeissue.com with thee sub-pages www.strangeissue.com/post1, www.strangeissue.com/post2 and www.strangeissue.com/post3. In the header of each page I have a list of icons for each social page (ex: Facebook, Google+, ...) and, in particular, an icon for email contact (ex: contact@strangeissue.com). In the source code , you will find the following:

    <a href="contact@strangeissue.com" class="email" target="_blank" style="opacity: 0.65;"><span>Email</span></a>

    Now, in Webmasters tools, I have the following crawl errors:

    post1/contact@strangeissue.com 404
    post2/contact@strangeissue.com
    404
    post3/contact@strangeissue.com
    404

    When I click on the link to see the source of the error for post1/contact@strangeissue.com, the "Linked from" tab shows the following:

    http://www.strangeissue.com/post1
    http://mysp.ac/ID
    (where ID is an alphanumerical code)

    I do not know what mysp.ac is. I wrote site:mysp.ac in Google search field and I found a lot of URLs with IDs targeting different pages on different websites. My first feeling is that it refers to some domain related to myspace (I have an account where I put links towards my posts).


    Could you please tell me what that site is about and how I can solve those errors where the email address is concatenated to the urls? Should I remove the email link from my header?
     
  2. mickyfu

    mickyfu Jr. VIP Jr. VIP Premium Member

    Joined:
    Dec 14, 2011
    Messages:
    5,285
    Likes Received:
    15,491
    Location:
    Jennifers Office.
    You may be the victim of a NSEO attack, people generate lots of 404's to mess your rankings up.
     
  3. keryanJames

    keryanJames Registered Member

    Joined:
    Jul 24, 2013
    Messages:
    93
    Likes Received:
    18
    Thank you, mickyfu, but I am not sure that it is an attack since one of two sources of the problem is the page itself, i.e.

    post1/contact@strangeissue.com with the page source of issue being http://www.strangeissue.com/post1

    But I do not understand why the bot tries to crawl that url.

    For the second source of issue (mysp.ac), I am waiting for concrete explanation from those of you that have knowledge about it.
     
  4. PrinceVisi

    PrinceVisi Elite Member

    Joined:
    Jan 11, 2012
    Messages:
    1,916
    Likes Received:
    1,009
    Occupation:
    BusinessMan
    Location:
    Tropoja

    If you use WordPress, then just put a redirection plugin and and you are good.

    Redirect every 404 to homepage and keep everything clean.
     
  5. keryanJames

    keryanJames Registered Member

    Joined:
    Jul 24, 2013
    Messages:
    93
    Likes Received:
    18
    PrinceVisi, I am using Wordpress. But what would be the explanation for that issue? Why does Google try to crawl the page url concatenated to the email address? I would better try to understand the reason and solve the issue at the root instead of redirecting uselessly.
     
  6. keryanJames

    keryanJames Registered Member

    Joined:
    Jul 24, 2013
    Messages:
    93
    Likes Received:
    18
    Any idea, guys?
     
  7. remon24

    remon24 Power Member

    Joined:
    Oct 3, 2012
    Messages:
    500
    Likes Received:
    404
    Location:
    NEW DELHI
    use robot.txt to block all these urls
     
  8. 808080Hat

    808080Hat Registered Member

    Joined:
    Feb 1, 2014
    Messages:
    65
    Likes Received:
    24
    Occupation:
    Freelance Software Developer/Architect
    Location:
    Berlin, Germany
    Your link is wrong, you need to write href = mailto: email adress and that in qoutes. At the moment you're giving the bot a real www-based link and he tries to crawl it, hence the 404.

    BHW moderation system is blocking me from writing it any better

    Here is the correct code: justpaste . it/ek7x
     
    Last edited: Feb 27, 2014