1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Static wordpress homepage Content (Page) just won't index

Discussion in 'Blogging' started by Bross, Aug 20, 2010.

  1. Bross

    Bross Senior Member

    Joined:
    Feb 6, 2010
    Messages:
    859
    Likes Received:
    355
    I test a few domains with static homepage (static page as homepage).
    Thing is... None of the content get indexed, making me think this is useless.

    1 of the domains even got an xrumer blast 10 days ago. The content just won't stick in the SE.

    Anyone experienced this?


    Cheers.
     
  2. Scripteen

    Scripteen Elite Member

    Joined:
    Sep 19, 2009
    Messages:
    1,811
    Likes Received:
    1,918
    Home Page:
    How old is your website / page? Did you run xrumer blast on the website before it gets even indexed? You are accelerating things man. you need some patience.
     
  3. Vegas

    Vegas Registered Member

    Joined:
    Dec 30, 2007
    Messages:
    52
    Likes Received:
    7
    No problems with that combination here. Most of my wordpress setups have a static page set as index and get indexed in google within 3-5 days, a week on the outside.

    What are you using in your ping list?
     
  4. Bross

    Bross Senior Member

    Joined:
    Feb 6, 2010
    Messages:
    859
    Likes Received:
    355
    Domains are indexed. Google picked the meta tags when the content was already there on homepage. But it didn't index the content itself.

    Ping list is updated and long, some other blogs I run index new posts within 5 minutes or so..

    Funny thing is, that 1 ping service took a sample of the content and linked back.. and this is the only thing indexed.

    I am not talking about indexing the blog, I am aiming a indexing the static page which is used as homepage's content.....

    Thanks..
     
  5. ajushi

    ajushi Registered Member

    Joined:
    May 27, 2010
    Messages:
    72
    Likes Received:
    19
    Occupation:
    Programmer
    Location:
    There's no place like 127.0.0.1
    No problems here. BTW, what title did you use for the homepage/static page? Are you using all in one SEO or other SEO plugins?
     
  6. silverflame44

    silverflame44 Registered Member

    Joined:
    May 17, 2009
    Messages:
    63
    Likes Received:
    14
    You shouldn't have any problems. 10 days isn't always a good enough test period. I think you should wait a little bit more. In addition, sometimes google indexes something, then it drops out of the indexing and comes back later. You should keep building backlinks and have faith! =P