1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Site indexed but... WTF?! (first time that happens)

Discussion in 'White Hat SEO' started by businessbira, Oct 1, 2009.

  1. businessbira

    businessbira Power Member

    Joined:
    Sep 26, 2008
    Messages:
    510
    Likes Received:
    301
    So guys, I have no idea why this is happening.

    I have a site that looks like it's indexed but...
    Check it out by yourself what i mean.

    Let's google -> site:lavoroparttime.org

    There is no title nor description on the SERP. I'm 100% sure my SEO friendly metatags are loaded and ready on my wp blog. They should be there, on Google listings.

    Have you any idea why this is happening?
     
  2. kaizersuzi

    kaizersuzi Junior Member

    Joined:
    Dec 31, 2008
    Messages:
    107
    Likes Received:
    132
    Location:
    Next Door2U
    Your robots meta has a noindex,nofollow. This could be the reason.
     
    • Thanks Thanks x 1
  3. speedy5044

    speedy5044 Regular Member

    Joined:
    Jul 29, 2008
    Messages:
    456
    Likes Received:
    993
    Occupation:
    IM
    I have the same problem with 1 of my forums using SMF , any idea?
     
  4. mrjinx

    mrjinx Regular Member

    Joined:
    Nov 10, 2008
    Messages:
    321
    Likes Received:
    291
    check your robot.txt file and also build google sitemap.

    jinx
     
    • Thanks Thanks x 1
  5. businessbira

    businessbira Power Member

    Joined:
    Sep 26, 2008
    Messages:
    510
    Likes Received:
    301
    Thanks everybody...

    The reason was that robots meta had a noindex,nofollow attribute. I checked that on

    Code:
    http://www.seocentro.com/tools/search-engines/metatag-analyzer.html
    Being on wordpress, I discovered that in the privacy settings "blog visibility" was set to

    "I would like to block search engines, but allow normal visitors"

    instead of

    "I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers"

    So, now everything is ok.

    Thanks again to everybody ;-)