1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question of Create Private Proxies on VPS?

Discussion in 'Proxies' started by ohio997, Aug 5, 2015.

  1. ohio997

    ohio997 Newbie

    Joined:
    May 5, 2014
    Messages:
    17
    Likes Received:
    1
    Hi, I am very very new to Linux.
    Before I used CC Proxy on Window server 2003, but only had one external IP.

    A few days ago, I tried to create my own Private Proxies on CentOS 5 VPS, and I spent almost 48 hours, but no luck.

    After edited # etc/squid/squid.conf
    then # squid -z

    I got the following error message:


    2015/08/05 23:41:19| aclParseIpData: Bad host/IP: '::1'
    2015/08/05 23:41:19| aclParseIpData: Bad host/IP: '::1'
    2015/08/05 23:41:19| decode_addr: Invalid IP address 'fc00::'
    2015/08/05 23:41:19| squid.conf line 10: acl localnet src fc00::/7 # RFC 4193 local private network range
    2015/08/05 23:41:19| aclParseIpData: Ignoring invalid IP acl entry: unknown first address 'fc00::'
    2015/08/05 23:41:19| decode_addr: Invalid IP address 'fe80::'
    2015/08/05 23:41:19| squid.conf line 11: acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged)
    2015/08/05 23:41:19| aclParseIpData: Ignoring invalid IP acl entry: unknown first address 'fe80::'
    2015/08/05 23:41:19| parseConfigFile: line 12 unrecognized: 'machines'
    2015/08/05 23:41:19| squid.conf line 37: refresh_pattern -i (/cgi-bin/|?) 0 0% 0
    2015/08/05 23:41:19| refreshAddToList: Invalid regular expression '(/cgi-bin/|?)': Invalid preceding regular expression
    2015/08/05 23:41:19| parseConfigFile: line 40 unrecognized: 'one below to disable this)'
    2015/08/05 23:41:19| aclParseAclLine: WARNING: empty ACL: acl myclients src ###.##.##.###
    2015/08/05 23:41:19| parseConfigFile: line 47 unrecognized: '/etc/squid/squid_access '
    2015/08/05 23:41:19| unrecognised basic auth scheme parameter 'childred'
    2015/08/05 23:41:19| parseConfigFile: line 59 unrecognized: 'request_header_access Allow allow all'
    2015/08/05 23:41:19| parseConfigFile: line 60 unrecognized: 'request_header_access Authorization allow all'
    2015/08/05 23:41:19| parseConfigFile: line 61 unrecognized: 'request_header_access WWW-Authenticate allow all'
    2015/08/05 23:41:19| ACL name 'all' not defined!
    FATAL: Bungled squid.conf line 69: http_reply_access allow all
    Squid Cache (Version 2.6.STABLE21): Terminated abnormally.
     
  2. fatboy

    fatboy Elite Member

    Joined:
    Aug 13, 2008
    Messages:
    1,618
    Likes Received:
    3,233
    Occupation:
    Retired
    Location:
    Old Peoples Home
    Did you have problems with my script? Think you are the person who asked about it a few days back?