1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with AutoBlog

Discussion in 'Blogging' started by maxken75, Feb 17, 2010.

  1. maxken75

    maxken75 Senior Member

    Joined:
    Nov 3, 2009
    Messages:
    872
    Likes Received:
    32
    I have some doubt on my niche website,
    Day one: started to found a good keyword with few competition
    Day two: i buyed a domain with my keyword and setup my autoblog with wordpress
    Day three: I writed one article about my keyword and published it on my autoblog, i have installed all my plugins set how, all for seo, amazon post, syncontent, etc
    Day four: i used scrapebox to make some comments and building some backlinks.
    Today, my website is on pages 10 from google, backlinks nothing from scrapebox.
    what's i wrong?
     
  2. macyzbor

    macyzbor Junior Member

    Joined:
    Jul 23, 2009
    Messages:
    147
    Likes Received:
    12
    Location:
    On the Sun
    nothings wrong it takes time, and actually you are doing very good
     
  3. Kharis

    Kharis Regular Member

    Joined:
    Mar 26, 2009
    Messages:
    274
    Likes Received:
    1,325
    Location:
    Down Under
    yeah it takes more than a day to get highly ranked, if you're on page 10 after a day that's pretty good
     
  4. husker999

    husker999 Junior Member

    Joined:
    Oct 6, 2008
    Messages:
    185
    Likes Received:
    662
    scrapebox can only be part of your backlinks strategy.
     
  5. maxken75

    maxken75 Senior Member

    Joined:
    Nov 3, 2009
    Messages:
    872
    Likes Received:
    32
    Not after one day but after two weeks....