1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Wordpress Yoast plugin

Discussion in 'Blogging' started by sTyaL, Apr 19, 2012.

  1. sTyaL

    sTyaL Newbie

    Joined:
    Apr 18, 2012
    Messages:
    2
    Likes Received:
    0
    Hi, I have a problem with a particular plugin "Yoast". I installed, configured but do not know how well .. But Google does not index article but the main page.


    I searched on google for an article on my blog and I found it, the description is good but when I clik on the link he send me to the mail page.

    Google do not index article but the first page.
    What should I do, as google to index my articles, not just the first page.

    I have this problem since i have instaled Yoast SEO plugin . What i have to change in the configuration to fix this problem?
     
  2. markhenry121

    markhenry121 Elite Member

    Joined:
    Oct 14, 2011
    Messages:
    2,149
    Likes Received:
    239
    which particular plug-in "Yoast" version you use ?
    Please download version 1.1.5. You set templates for titles and Meta descriptions for all types of pages. Check Robots Meta configuration, Canonical, Breadcrumbs, and Permalink clean up, XML Sitemaps, RSS enhancements, Edit your robots.txt and .htaccess, and clean up head section.
     
  3. sTyaL

    sTyaL Newbie

    Joined:
    Apr 18, 2012
    Messages:
    2
    Likes Received:
    0
    thanks ..

    i have another question. i have instaled robots meta and when i post a new article in the right side i have
    index, follow
    index, nofollow
    noindex, follow
    noindex, nofollow
    what do i chose?
     
  4. WPRipper

    WPRipper Supreme Member

    Joined:
    Mar 24, 2010
    Messages:
    1,376
    Likes Received:
    1,493
    Location:
    Proudly romanian
    Always use index, follow. Search before you make this kind of post.