1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with iMacro and csv file

Discussion in 'Black Hat SEO Tools' started by marie12, Apr 4, 2012.

Tags:
  1. marie12

    marie12 Newbie

    Joined:
    Apr 4, 2012
    Messages:
    4
    Likes Received:
    0
    Hello,
    I have a problem with my csv file.
    Without variable, the imacro works, but when I use {{!COL1}}, it doesn't work anyway.

    A piece of my imacro :
    SET !DATASOURCE wp_cp.csv
    SET !DATASOURCE_COLUMNS 2
    SET !DATASOURCE_LINE {{!LOOP}}
    URL GOTO=xxx
    TAG POS=1 TYPE=A ATTR=TXT:Nouvel<SP>article
    WAIT SECONDS=3
    TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:* ATTR=ID:title CONTENT={{!COL1}}

    My csv file content on one line :
    bobo,"Il n'y a guère que 2 solutions possibles"
    I created the csv file with Excel at the begining, and after opened it in Textedit to change the point comma to comma, and to add double quotes. I read the iopus information about the csv file conformity, but found nothing to help me...
    What's wrong ?
    Someone can help ?
     
  2. Karim

    Karim Newbie

    Joined:
    Feb 5, 2012
    Messages:
    28
    Likes Received:
    5
    Location:
    Tunisia
    I think you should write the csv line like this :

    "bobo,Il n'y a guère que 2 solutions possibles".

    Try that and see what you get.
     
    Last edited: Apr 4, 2012
  3. christoss1959

    christoss1959 Senior Member

    Joined:
    Nov 25, 2010
    Messages:
    899
    Likes Received:
    1,156
    Home Page:
    are you including the quotes or did you just use them to indicate the text?
     
  4. 45415

    45415 Junior Member

    Joined:
    Feb 5, 2009
    Messages:
    194
    Likes Received:
    92
    Is your .csv file in the right folder? You could specify the full path.
    Have you tried to put both columns in quotes?
    Do you get an error or is the input field empty after the iMacro is done?
     
  5. marie12

    marie12 Newbie

    Joined:
    Apr 4, 2012
    Messages:
    4
    Likes Received:
    0
    Thank you a lot for your attention !

    Karim : it doesn't work

    christoss1959 : the quotes are indicating the text, I put them to have the whitespaces into the worlds, in the second cell.

    Donor : if I write the full path, it doesn't work (I am on Mac) :
    SET !DATASOURCE /Users/xxx/iMacros/Datasources/wp_cp.csv
    If I write :
    "bobo","Il n'y a guère que 2 solutions possibles"
    it doesn't work too.
    It's no message error, but the field is empty after the iMacro is done (and activated with a blue border).

    Thank you in advance for your replies.
     
  6. 45415

    45415 Junior Member

    Joined:
    Feb 5, 2009
    Messages:
    194
    Likes Received:
    92
    Not sure about Mac, but on Windows (depending on your regional settings) the comma should be replaced with semicolon. Maybe that is the problem.
     
  7. KenWingJitsu

    KenWingJitsu Regular Member

    Joined:
    Apr 5, 2008
    Messages:
    290
    Likes Received:
    57
    Replace the white spaces with (SP) but use the Angled brackets
     
  8. marie12

    marie12 Newbie

    Joined:
    Apr 4, 2012
    Messages:
    4
    Likes Received:
    0
    Hello, and thank you for your replies.

    I tried something :
    Yesterday, I have a csv file that worked on another iMacro. So I took this file and I modified the content like that :
    "bobo","Diffusion en streaming sur le Net"
    This file, called "arfoo_300c3.csv", works fine with my new iMacro.

    Now, on Excel, I create a new file xls, with the same content (2 cells), and I save it on csv format. I open it in TextEdit to change the ";" to "," and to put double quotes around the cells, like this :
    "bobo","Diffusion en streaming sur le Net"
    This file, called wp_cp_kenka3.csv" doesn't work... :(

    Why ? What's the differnce between the 2 files ? I don't understand...
    Someone have an idea ?

    Look at the 2 files, into the files.zip...
     

    Attached Files:

  9. 45415

    45415 Junior Member

    Joined:
    Feb 5, 2009
    Messages:
    194
    Likes Received:
    92
    The 2 csv files look the same.
    No idea, what could be the problem, but I had a similar problem - merging many files into 1 csv and iMacros couldn't read it.
    I solved it by simply making a new text file and copying the contents of large csv file to the text file. Then I rename the text file to file_name.csv and then it works.
    Doesn't make any sense to me, but at least it works.
     
    • Thanks Thanks x 1
  10. marie12

    marie12 Newbie

    Joined:
    Apr 4, 2012
    Messages:
    4
    Likes Received:
    0
    OK, I'm going to follow your counsel. You are right : sometimes, the important is that works, in a way or another...
    But it makes me to spend more time, and iMacro is normally to spend less time...

    Thank you for having take time to reply to me.