1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem With Elegant Themes...

Discussion in 'Blogging' started by James2, Mar 27, 2013.

  1. James2

    James2 Supreme Member

    Joined:
    Jun 3, 2011
    Messages:
    1,204
    Likes Received:
    1,035
    Location:
    London, England
    Hell people,

    I have been having a problem with some elegant themes. Some of the ones with primary and secondary menus (Aggregate for example) won't allow me to structure sub menus. I swapped over to Twenty Eleven, same problem. TBH, I have been using downloaded versions of Elegant Themes from on here. I am wondering if they have messed with the code or something.

    Anyone had the same problems and if so, how did you fix it?

    Thanks in advance for your time,

    James :)
     
  2. AnotherOne

    AnotherOne Senior Member

    Joined:
    Nov 28, 2011
    Messages:
    950
    Likes Received:
    189
    Occupation:
    SQA
    Location:
    JMeter & Selenium
    No issue at my end on ElegantThemes.
    Try it on TwentyTwelve.

    P.S
    I don't use Twenty - (you name it) theme and I delete them as soon as I upload my own theme.
     
    • Thanks Thanks x 1
  3. Endire

    Endire Elite Member Premium Member

    Joined:
    Mar 27, 2012
    Messages:
    1,756
    Likes Received:
    1,061
    Gender:
    Male
    James,

    You could try installing the following code in your wp-config.php file,

    define('SCRIPT_DEBUG', true);
    or
    define('CONCATENATE_SCRIPTS', false);

    It has been known to fix issues related with admin dropdown menus.

    If that doesn't work, you could try turning off minification in your template if you have it enabled. Have you enabled minifcation of JS or CSS files anywhere else like in .htaccess? If so try disabling that and seeing if the issue is fixed.

    Also, make sure you don't have any conflicting plugins. This is a much more difficult element to diagnose unless you were paying attention to when the menu stopped working after you installed something.

    Hope that helps,

    Shawn
     
    • Thanks Thanks x 2
  4. Duffers5000

    Duffers5000 Elite Member

    Joined:
    Apr 1, 2012
    Messages:
    2,471
    Likes Received:
    7,683
    More good advice from Shawn.... I'm not sure what your exact prob is as its a while since I used Elegant but I had an account and used legit themes but found them a pain in the arse eventually. Good looking themes but you could spend 4-5 hours trying to work out simple things.
     
    • Thanks Thanks x 1
  5. James2

    James2 Supreme Member

    Joined:
    Jun 3, 2011
    Messages:
    1,204
    Likes Received:
    1,035
    Location:
    London, England
    It worked! Cheers Shawn. True expert :)
     
    • Thanks Thanks x 1