1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help, my Wordpress site doesn't recognize me as Admin

Discussion in 'Web Design' started by mummie, Dec 22, 2016.

  1. mummie

    mummie Newbie

    Joined:
    Dec 1, 2016
    Messages:
    23
    Likes Received:
    9
    Gender:
    Male
    Occupation:
    Being poor
    I can enter my WEBSITE.com/wp-admin but when I only enter WEBSITE.com.

    There is no admin topbar and when I check pageviews it's increased every time I enter my site.

    Anyone ever has the same issue as mine?? How to fix it thank you!
     
  2. Motherdex

    Motherdex Regular Member

    Joined:
    Dec 31, 2015
    Messages:
    333
    Likes Received:
    87
    Gender:
    Female
    I don't know for sure that this is the answer but when I had a similar issue I logged in through my hosting account and accessed my dashboard that way
     
  3. Conor

    Conor Elite Member

    Joined:
    Nov 7, 2012
    Messages:
    3,579
    Likes Received:
    5,964
    Gender:
    Male
    Location:
    South Africa
    Home Page:
    Do you have access to the database? You can create a new admin from there with the following instructions:
    http://www.inmotionhosting.com/support/edu/wordpress/333-add-admin-via-mysql
     
    • Thanks Thanks x 1
  4. Shoel2013

    Shoel2013 Newbie

    Joined:
    May 1, 2013
    Messages:
    42
    Likes Received:
    5
    Gender:
    Female
    You need to contact your Hosting server for better understanding your issues
     
  5. shifubill

    shifubill Jr. VIP Jr. VIP

    Joined:
    Oct 5, 2013
    Messages:
    323
    Likes Received:
    47
    It sounds like either your theme doesn't support the WordPress toolbar (it's not only for admin, btw), or it's been disabled, or you're being logged out. I don't know about the pageview issue, but check your settings and/or theme options for the rest.
     
  6. mummie

    mummie Newbie

    Joined:
    Dec 1, 2016
    Messages:
    23
    Likes Received:
    9
    Gender:
    Male
    Occupation:
    Being poor
    I can actually access my dasboard, and if I enter my site through dashboard I can see the admin top bar.

    I'll try it.

    Yes if it's not getting better I will need to do that.

    At first my theme worked perfectly, but after a while this just happened. Actually it's just happened today.
    I'm sure it's not disabled, I just deleted cache and refresh my homepage and I could see the top bar again, but in a minute when I refresh the homepage again my top bar was gone.
    Then entered another page, and the top bar was still there. Some pages has top bar, some don't.


    Oh god.
     
  7. shifubill

    shifubill Jr. VIP Jr. VIP

    Joined:
    Oct 5, 2013
    Messages:
    323
    Likes Received:
    47
    Try disabling your plugins and see if that fixes it.
     
    • Thanks Thanks x 1
  8. KHer0

    KHer0 Supreme Member

    Joined:
    Mar 22, 2011
    Messages:
    1,363
    Likes Received:
    1,246
    Occupation:
    Architect
    This your problem. It's something with php coding. And the only way to miss your coding is plugin conflict. Disable plugins one by one, clear cache till you know which one causes the problem.
     
    • Thanks Thanks x 1
  9. mummie

    mummie Newbie

    Joined:
    Dec 1, 2016
    Messages:
    23
    Likes Received:
    9
    Gender:
    Male
    Occupation:
    Being poor
    Yes I tried it and the it works! It's because of some plugins..

    At first I was worried about getting hacked o_O
     
    • Thanks Thanks x 1
  10. crazymind

    crazymind Newbie

    Joined:
    Jan 2, 2016
    Messages:
    35
    Likes Received:
    3
    just type ur website url and on the end addd /login , and in it will show you
     
  11. webdev357

    webdev357 Junior Member

    Joined:
    Oct 18, 2016
    Messages:
    102
    Likes Received:
    10
    Occupation:
    Web Designer
    Location:
    California
    what i usally do sometimes is, ftp in and delete plugin's one by one. sometimes I even delete the entire theme. give that a try