1. This website uses cookies to improve service and provide a tailored user experience. By using this site, you agree to this use. See our Cookie Policy.
    Dismiss Notice

One link above all in google images

Discussion in 'White Hat SEO' started by sseeeeeereg, Nov 27, 2019.

  1. sseeeeeereg

    sseeeeeereg Newbie

    Joined:
    Nov 13, 2014
    Messages:
    7
    Likes Received:
    2
    Gender:
    Male
    Sorry if it's not a correct category for that question. I few days ago I finished my website and send my sitemaps to search console. Yesterday I was checking indexing progress and everything was fine, except Google Images 'cause every indexed image has above the title of artilcle a link to one of my post (and literally every image have a link to that one article).

    [​IMG]

    Can you know what it can be or where to search more informations about that? I'm using Seopress plugin and Schema but I doesn't see any option that could trigger this.
     
  2. pentagon3

    pentagon3 Newbie

    Joined:
    Dec 3, 2017
    Messages:
    16
    Likes Received:
    5
    Gender:
    Male
    Occupation:
    SEO Consultant
    I guess you miss configured your SEO Plugin, or Schema.ORG on posts/pages, etc.

    You must have chosen one "default pic" which shows everywhere. It's easy to chose the attached picture/highlighted picture.

    Example, with AllInOneSeo (the plugin I use), it's really easy to configure the image for google directly below every post (+ a general rule like "the image for google is the highlighted one".

    After that, and after many crawls, more of your images will be on GGimg.
     
  3. sseeeeeereg

    sseeeeeereg Newbie

    Joined:
    Nov 13, 2014
    Messages:
    7
    Likes Received:
    2
    Gender:
    Male
    I do not have a problem with indexing images, but with a one particular link that shows above every indexed post title. Sorry if it wasn't clear enough. Like you can see on picture below there are three different articles but above all of them there is a one particular link to article on my website. The problem is that I don't know why and what can cause that problem.

    [​IMG]