1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

One backlink - rankings dropped considerably

Discussion in 'Black Hat SEO' started by Cheeky92, Jul 2, 2015.

  1. Cheeky92

    Cheeky92 Junior Member

    Joined:
    May 23, 2013
    Messages:
    111
    Likes Received:
    16
    Hey guys,

    I've got a new-ish website (4-5 months) and it is in a niche which will never be able to build its own links naturally.

    I linked one of my old websites (which doesn't have a penalty on it, but does have SOME spammy links to it) which is in EXACTLY the same niche to it (with one link in a post).

    A few days later my other website had a big ranking hit for a lot of keywords, is this likely to be the cause? I don't think there will be any (or many) other backlinks to my new site :S

    Really confused and would really appreciate some help, thanks guys!
     
    • Thanks Thanks x 1
  2. diesel1

    diesel1 Senior Member

    Joined:
    May 22, 2013
    Messages:
    934
    Likes Received:
    226
    .

    You only build one link..

    Whatever the reason(s), I do not think it is due to that one link
     
  3. ja1myn

    ja1myn Senior Member

    Joined:
    Feb 3, 2012
    Messages:
    817
    Likes Received:
    306
    I doubt that one link is the cause of it.
     
  4. Losek

    Losek Junior Member

    Joined:
    Jan 24, 2014
    Messages:
    124
    Likes Received:
    14
    Location:
    Spain
    Did you isolated the ranking facts? Or did you do something more?
     
  5. djp371

    djp371 Elite Member

    Joined:
    Apr 20, 2009
    Messages:
    2,074
    Likes Received:
    348
    Occupation:
    Internet marketing
    Location:
    United States
    Home Page:
    Most like you were not impacted by one link. Did your site have other unnatural links before that?
     
  6. hanssolo

    hanssolo Jr. VIP Jr. VIP

    Joined:
    Oct 23, 2012
    Messages:
    588
    Likes Received:
    62
    Are you sure it's not dancing? I will give it a week. It's very unlikely a link causes that.