1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Old site indexed, new site not

Discussion in 'Black Hat SEO' started by Adrianx, Nov 10, 2014.

  1. Adrianx

    Adrianx Registered Member

    Joined:
    Jun 13, 2010
    Messages:
    64
    Likes Received:
    3
    Location:
    Spain
    Hi, I've a problem... My site was indexed by Google 2 months ago, but my site was not finished, so Google indexed pages that now I don't have in my site.

    Have passed more than 1 month since I finished my site and Google stills has my old site indexed, not my new site. I'm using Yoast SEO also.

    How can I do to get my new site indexed. I've XML sitemap but I don't want to use Webmaster Tools to add it because I'll add PBN links.

    Any ideas? I've just used a ping service but I'm not sure if it will work or not.

    Thanks.
     
  2. ggguuuttt

    ggguuuttt Junior Member

    Joined:
    Aug 2, 2014
    Messages:
    104
    Likes Received:
    12
    You need to get google to crawl your website.
     
  3. SEO Power

    SEO Power Elite Member

    Joined:
    Jul 14, 2014
    Messages:
    2,637
    Likes Received:
    680
    Occupation:
    Self employed
    Location:
    Houston, TX
    Make sure you aren't blocking Google in your WordPress settings or robots.txt file. Also, use archive.org to find out if your domain has been used and penalised in the past.
     
    • Thanks Thanks x 1
  4. JakeTutorials

    JakeTutorials Newbie

    Joined:
    Jun 19, 2014
    Messages:
    21
    Likes Received:
    1
    See how ur pinging goes and then come back because I might have a solution.
     
  5. Adrianx

    Adrianx Registered Member

    Joined:
    Jun 13, 2010
    Messages:
    64
    Likes Received:
    3
    Location:
    Spain
    Oh my god! I opened my robots.txt file and says this:

    User-agent: *
    Disallow: /

    It was blocking the entire site! I never touched that file! and I have all my settings correct...I'm sure it's some kind of Yoast plugin problem lol. Thanks for your answers.
     
  6. darkblackcat

    darkblackcat Newbie

    Joined:
    Nov 11, 2014
    Messages:
    7
    Likes Received:
    0
    do 301 redirect from old pages to new pages., using htaccess.
     
  7. avalon1981

    avalon1981 Regular Member

    Joined:
    Dec 6, 2013
    Messages:
    412
    Likes Received:
    58
    Occupation:
    Twidium Team
    For quick indexing after you altered your robots file you may create a html "sitemap", put it somwhere on your site and send a link on it with twitter.
    But it is better to leave it as it is for now to make it look natural.
     
  8. blackcoffee7

    blackcoffee7 Junior Member

    Joined:
    Sep 27, 2014
    Messages:
    141
    Likes Received:
    46
    Home Page:
    Indexing is much faster if you have a sitemap.xml on your website.
     
  9. gazmo

    gazmo Junior Member

    Joined:
    Jun 1, 2013
    Messages:
    121
    Likes Received:
    66
    Occupation:
    Software Engineer
    Location:
    Bulgaria
    OP, can you specify what other plugins you used on this site?

    I've never had such problems with Yoast, could be it but I'm curious what might have caused this.
     
  10. Adrianx

    Adrianx Registered Member

    Joined:
    Jun 13, 2010
    Messages:
    64
    Likes Received:
    3
    Location:
    Spain
    I have a sitemap, I also uploaded it to Webmaster tools (I heard that better not to use GWT when using blackhat tactics but I think it doesn't matter), now I need to wait to see what happens.

    Some plugins I have are: Wordfence Security, Udraft Plus, WP Super Cache, BWP Minify... maybe the problem is because of Wordfence or WP Super Cache, who knows...lol One thing I remmember is to change Wordpress to not to index my site (because I was doing it and it was not finished) but when I finished, I deactivated that. Maybe is because that...

    Regards.