1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No links showing up

Discussion in 'White Hat SEO' started by colgoose, Apr 21, 2010.

  1. colgoose

    colgoose Newbie

    Joined:
    Apr 14, 2010
    Messages:
    33
    Likes Received:
    4
    Hi all,

    I have set up a wp site and have made many articles and submitted them to ezine, go articles etc and have made squidoo lenses, hub pages etc and then I have used software called traffic bug to submit to directories, social bookmark and ping everything.

    All of these articles and web 2.0 sites have all been indexed and a couple of these are ranking 9 and 10 in google.

    My site is stuck at position 4 and this is not a competitive search term.

    My problem is that my site is only showing 2 backlinks to my site and is not showing up any backlinks from all of the articles etc even though they are ranking in the top 10 and all of the other articles are indexed.

    All of the links in the articles have got my main keyword in them.

    |How can I get these links to pass onto my site?

    Thanks for any advice,

    Matt
     
  2. kez1000

    kez1000 Supreme Member

    Joined:
    Jul 24, 2009
    Messages:
    1,402
    Likes Received:
    1,340
    Location:
    UK
    you have to give it some time
     
  3. boffmaster

    boffmaster Junior Member

    Joined:
    Jun 1, 2009
    Messages:
    144
    Likes Received:
    32
    If you are suspicious about whether google knows about your article then take a unique sentence from an article submitted, put it in quotes and search for it with google. If it finds it then google knows about your article and don't worry if yahoo's site explorer or some other tool doesn't report your links.

    As Kez1000 mentioned it does take time. I often see the fruits of my labour about 2 weeks after. For example, I had a youtube channel with a PR of zero and then built links to it and 2 weeks later it was PR4. Meaning my link from the channel was passing some better juice.

    Hope that helps a bit. Hope I understood you.
     
  4. colgoose

    colgoose Newbie

    Joined:
    Apr 14, 2010
    Messages:
    33
    Likes Received:
    4
    Thanks guys,

    It's been about 4 weeks now.

    The main thing that I can't get my head around is that 2 of my articles have been in the top 10 results for about 3 weeks but I still see no value from the links in their articles.

    Is this normal, and still just a case of waiting for the links to show up?
     
  5. boffmaster

    boffmaster Junior Member

    Joined:
    Jun 1, 2009
    Messages:
    144
    Likes Received:
    32
    What do you mean by getting no value.
    Did you expect your site to climb form position 4 to 3 or do you mean that when you look at your website statistics (using awstats or google analytics) that you see no one clicking on the links from your articles.

    After 4 weeks you are being a bit impatient. Some people are happy to be even indexed after 4 weeks. Just keep adding backlinks and you'll be fine. Also remember that just because a website has a PR of 9 doesn't mean that the page your article is on has a PR of 9. It may have no PR at all. So you may want to build some backlinks to your article posts as well to improve their PR a bit.

    Hope that helps
     
  6. colgoose

    colgoose Newbie

    Joined:
    Apr 14, 2010
    Messages:
    33
    Likes Received:
    4
    I mean that 2 of the articles that I wrote have got into the top 10 positions. hey were ezine and a hubpage. Both of these articles have got a text link to my main site but when I do a backlink search for my main site, neither of the links from the articles show up.

    Is this normal?
     
  7. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    PM me your url and I will check to see what links are showing. I know that a lot of link checkers are not that accurate but I will try for you.
     
    • Thanks Thanks x 1