1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No backlinks to my site

Discussion in 'Link Building' started by MisterTwister, Feb 9, 2010.

  1. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    My website got indexed by google yesterday so I thought I would build a few backlinks.

    Someone created 180 forum accounts with my url in them using xrummer then I pinged them using the most recent ping list I could find.

    I expected to see at least a few backlinks today but nothing.

    Any Ideas?
     
  2. drdankmendez

    drdankmendez Junior Member

    Joined:
    May 30, 2008
    Messages:
    194
    Likes Received:
    316
    Location:
    In front of my computer
    It takes a little while for backlinks to show up. Give it some time and you should start to see them.
     
    • Thanks Thanks x 1
  3. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    I thought pinging them brought them straight to googles attention.

    Will sit back and wait.
     
  4. peter2002

    peter2002 Senior Member

    Joined:
    Jul 8, 2009
    Messages:
    1,120
    Likes Received:
    24,314
    Occupation:
    Internet Marketer, Degrees in Business and Psychol
    Location:
    USA
    It still takes some time to see results. Just be patient.
     
  5. mindhunter77

    mindhunter77 Junior Member

    Joined:
    Oct 17, 2008
    Messages:
    160
    Likes Received:
    23
    what did you use to ping 180 urls?
     
  6. nimbus49

    nimbus49 Elite Member

    Joined:
    Oct 28, 2008
    Messages:
    2,274
    Likes Received:
    283
    Home Page:
    Most will show, but not all....give it a few more days.
     
  7. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    xrummer created the accounts and I used masspinger from this forum.

    I also used statblaster so would expect some links there.

    Been almost 3 days and not one backlink!

    The domain is apple-ipads . n e t if anyone wants a look.
     
  8. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    Bump ;)
     
  9. sidnettwo

    sidnettwo Junior Member

    Joined:
    Jun 5, 2009
    Messages:
    135
    Likes Received:
    60
    Nope, I can't see any backlinks there. How do you know it's indexed? It isn't showing for a goog search of it's url. Maybe submit to digg?
     
  10. tripper101

    tripper101 Registered Member

    Joined:
    Dec 22, 2007
    Messages:
    75
    Likes Received:
    330
    Just go to google and put in your URL link like this.
    site:your-url-goes-here.com

    If its in google, it will show the pages you have indexed in google.
    make sure you put you URL into googles index manually.

    http://www.google.com/addurl/
     
  11. tripper101

    tripper101 Registered Member

    Joined:
    Dec 22, 2007
    Messages:
    75
    Likes Received:
    330
    here is your site in google: Results 1 - 7 of 7 from apple-ipads.net. (0.17 seconds)
    Search Results
     
  12. jjustine

    jjustine Newbie

    Joined:
    Jan 25, 2010
    Messages:
    8
    Likes Received:
    0
    Just be patient and you will see result. Mine takes around a month i guess when i see the backlinks.


    kind regards

    sam
    x
     
  13. MisterTwister

    MisterTwister Regular Member

    Joined:
    Feb 12, 2009
    Messages:
    458
    Likes Received:
    160
    Thank you all for your advice - Patience is obviously a virtue I don't possess!
     
  14. dailyearner

    dailyearner BANNED BANNED

    Joined:
    May 16, 2009
    Messages:
    314
    Likes Received:
    9
    you should wait 1 month
    your backlinks will appear in yahoo
     
  15. fly2010

    fly2010 Newbie

    Joined:
    Feb 10, 2010
    Messages:
    14
    Likes Received:
    1
    I submit my articles to digg before, but when I site my domain in Google, I only only see Google indexes my aritcles instead of digg.com/xxxxx. Any thoughts?
     
  16. fly2010

    fly2010 Newbie

    Joined:
    Feb 10, 2010
    Messages:
    14
    Likes Received:
    1
    :pI saw them
     
  17. ebiz101

    ebiz101 Regular Member

    Joined:
    Feb 16, 2010
    Messages:
    212
    Likes Received:
    98
    T index all the URLS will take time.So allow Google few more days to cache all the profile URLs.
     
  18. virtualwebmarket

    virtualwebmarket Newbie

    Joined:
    Feb 11, 2010
    Messages:
    32
    Likes Received:
    1
    Lets Google spider the site and the links for few more times and you will see them indexed