1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[newbie] trouble with incoming links

Discussion in 'White Hat SEO' started by loginname, Oct 18, 2009.

  1. loginname

    loginname Regular Member

    Joined:
    Oct 1, 2008
    Messages:
    371
    Likes Received:
    13
    hey

    Google reports that nobody are linking to my site currentsignature.com,
    But I'm using the linkjuicer and with linkjuicer I've got about 20 links (3 made each day), in addition I have a blog and an article uploaded which points currentsignature.com....

    so I wonder what I do wrong as google reports nobody are linking to me :confused:
     
  2. TermsB

    TermsB Senior Member

    Joined:
    May 19, 2009
    Messages:
    1,076
    Likes Received:
    734
    Location:
    USA
    It's not instant, 1-4 weeks is normal for new backlinks to show. Go to Yahoo and do a site:yoursitehere.com search and see if you have any inlinks. They show on Yahoo most of the time before they will on Google. Also with Google new domains are put on basically a probation period when they are fresh to the system to make sure they are not too spammy or have malicious content on them before they are indexed.

    Keep in mind Google doesn't count all backlinks, it deems some too spammy or coming from an unrelated source.
     
    Last edited: Oct 18, 2009
  3. loginname

    loginname Regular Member

    Joined:
    Oct 1, 2008
    Messages:
    371
    Likes Received:
    13
    thanks, In Yahoo I got 9 inlinks.. so it looks like I have to be patient
     
  4. nho99

    nho99 Newbie

    Joined:
    Oct 16, 2009
    Messages:
    20
    Likes Received:
    5
    Home Page:
    lol it's opposite on mine. I have 25 links in google but none in yahoo