1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help with Wordpress Theme loading issue.

Discussion in 'Blogging' started by hits79, Nov 23, 2012.

  1. hits79

    hits79 Regular Member

    Joined:
    Feb 11, 2011
    Messages:
    269
    Likes Received:
    114
    Occupation:
    HP Customer Engineer
    Location:
    New Jersey
    Hey guys, I just started blogging about my hobby again. I bought this theme off themeforest, and with no help from there, I thought I ask on bhw forums to see if someone can help me with my site. Basically what is going is my website is loading slow and I can't figure out what is causing this. I believe it is the theme, as it only happens when I activate the theme. Other themes it works perfect, loading time, all the plugins etc. The theme I currently have on my website is loading slow. It takes few seconds for the site to load up all the way. I was wondering if anyone would mind helping me out and see if they can tell what is causing the issue and how to resolve it.

    I do not want to post my link to my site here, as I am not sure if it is allowed. So please reply back here, and I will pm you my link to my website.
     
  2. mrsix

    mrsix Power Member

    Joined:
    Sep 13, 2008
    Messages:
    785
    Likes Received:
    465
    Location:
    PNW
  3. hits79

    hits79 Regular Member

    Joined:
    Feb 11, 2011
    Messages:
    269
    Likes Received:
    114
    Occupation:
    HP Customer Engineer
    Location:
    New Jersey
  4. ponting99

    ponting99 Newbie

    Joined:
    Mar 9, 2011
    Messages:
    12
    Likes Received:
    0
    Occupation:
    Home
    Location:
    Åre sweden
    I use: W3 Total Cache and cloudflare, very fast and No need for anything else! gives 95 of 100 on Y Slow!!
    and Optimus, Ok it german but works Automatic to optimize allt pitchures.
     
  5. WPRipper

    WPRipper Supreme Member

    Joined:
    Mar 24, 2010
    Messages:
    1,379
    Likes Received:
    1,493
    Location:
    Proudly romanian
    If you say is the theme, then this is ur answer. To be sure load a complex theme, something big and see how server works.
     
  6. DavidG

    DavidG Newbie

    Joined:
    Aug 14, 2009
    Messages:
    33
    Likes Received:
    3
    yeah its the server, might want to take some stuff out and back in.
     
  7. AnotherOne

    AnotherOne Senior Member

    Joined:
    Nov 28, 2011
    Messages:
    919
    Likes Received:
    187
    Occupation:
    SQA
    Location:
    JMeter & Selenium
    Do you mind sharing the theme name here?
    In the meantime backup your original Apache/IIS server logs and clear the other one. After that load that problematic theme and check the logs for server load.
     
  8. wickedguy

    wickedguy Supreme Member

    Joined:
    Jul 22, 2009
    Messages:
    1,402
    Likes Received:
    1,379
    Location:
    BHW--> South Africa
    Home Page:
    maybe the theme is calling home and their server takes long to respond?
     
  9. thiard

    thiard Newbie

    Joined:
    Oct 7, 2012
    Messages:
    30
    Likes Received:
    3
    maybe the theme is not compatible with your hosting server. Check your server log
     
  10. hits79

    hits79 Regular Member

    Joined:
    Feb 11, 2011
    Messages:
    269
    Likes Received:
    114
    Occupation:
    HP Customer Engineer
    Location:
    New Jersey
    I dont think it's the server, it's hosted on hostwinds. But I will try this anyways.

    Actually, here the link for them.
    For your other recommendations, god I wish I knew how to do that. I will do some research and see what I can find.

    I am not sure, beat the heck out of me. But i did notice lots of script in the header file. Dunno :/

    I never knew that themes can not be compatible with server. If it wasn't wouldn't the url not work at all when the themes activate?
     
  11. AnotherOne

    AnotherOne Senior Member

    Joined:
    Nov 28, 2011
    Messages:
    919
    Likes Received:
    187
    Occupation:
    SQA
    Location:
    JMeter & Selenium
    You're using nulled (free, cracked, you name it) version of this theme?
     
  12. hits79

    hits79 Regular Member

    Joined:
    Feb 11, 2011
    Messages:
    269
    Likes Received:
    114
    Occupation:
    HP Customer Engineer
    Location:
    New Jersey
    Nope bought both of them. I asked the designer himself first on this thread, but just either ignores it or delete my post :/
     
  13. gvncerri

    gvncerri Regular Member

    Joined:
    Jun 10, 2011
    Messages:
    348
    Likes Received:
    71
    Occupation:
    Internet Marketer
    Location:
    Italy
    Home Page:
    Hi, the problem is this: you like the theme and you paid for it. But it's a slow theme so you have to choose another one, anyway

    Your hosting server has nothing to do with this. You tested your site with Twenty Eleven and it loaded fast.


     
  14. anthony_joddie

    anthony_joddie Newbie

    Joined:
    Apr 4, 2011
    Messages:
    1
    Likes Received:
    0
    your theme has big size slideshow, you can try to optimize the images before uploading them. if you are using photoshop, you can try to Ctrl + Alt + Shift + S (choose medium) to reduce the picture file size