1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help with Wordpress, posts not showing up.

Discussion in 'BlackHat Lounge' started by dgfalk, Apr 12, 2011.

  1. dgfalk

    dgfalk Power Member

    Joined:
    Apr 26, 2010
    Messages:
    687
    Likes Received:
    94
    Wondering if someone can help me with wordpress problem Im having. I started a new site and I added 4 posts to it, published them and left it alone for a few weeks. Today I went to take a look at my site to make sure everythings working good and I noticed all 4 of the posts are blank.

    On my main page I can see the 4 links on the right sidebar under "Recent Posts", I can click each link and it takes me to the post but all it shows is the H1 title. When I log into the Admin panel and go to edit the post it shows the entire 500 word article. When I click Preview it loads up the page, but again it will jsut show the title.

    Also I am using a 2 column theme and I notcied when Im on the post page the sidebar is also blank, it should show "pages" "categories" and "recent posts" but it doesnt. I delete the theme I was using and reuploaded it but that didnt fix it.

    Does anyone have any idea why it is doing this??
     
  2. Autumn

    Autumn Elite Member

    Joined:
    Nov 18, 2010
    Messages:
    2,197
    Likes Received:
    3,044
    Occupation:
    I figure out ways to make money online and then au
    Location:
    Spamville
    Check single.php in your theme to make sure that the the_content() function is there and also make sure you're not resetting the $post->ID anywhere before that function is called (eg with a plugin).

    Try looking at your site using the default theme - that will tell you whether the problem is your theme or something else with WP. You can also try disabling all plugins and then re-enabling them one by one to see if that fixes it.
     
    • Thanks Thanks x 1
  3. ScrapeBoss

    ScrapeBoss Elite Member Premium Member

    Joined:
    Nov 25, 2010
    Messages:
    1,865
    Likes Received:
    669
    Location:
    123.456.789.012.345.678.901.234.567
    Home Page:
    Install a new theme and check if the posts will appear.

     
    • Thanks Thanks x 1
  4. dgfalk

    dgfalk Power Member

    Joined:
    Apr 26, 2010
    Messages:
    687
    Likes Received:
    94
    I activated the default twenty ten theme and it worked fine so there was something wrong with my previous theme. I decided I dont even want to use that theme anyways so Im not gonna try and figure out exactly what it was.

    Thanks for the help!