1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help to install openvpn on vps

Discussion in 'Proxies' started by chris0147, Oct 13, 2011.

  1. chris0147

    chris0147 Junior Member

    Joined:
    Jul 21, 2009
    Messages:
    138
    Likes Received:
    3
    Hi there,

    My name is chris, I'm a member on a forum called blackhatworld. I needs your urges help, I have just rented xen virtual private server that come with 128mb of ram. I have installed CentOS 5.5 32-bit pygrub on my server and I have a little problem with foward IP.


    what I have input the command in putty:

    Code:
    iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT

    Here's what I'm getting:

    Code:
    iptables v1.3.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.

    I tried to find the solution and I tried to upgrade the kernel version, but the problem still fails there. I kept getting the same errors over and over again, I have tried three tutorials which those are:

    http://www.vpsyou.com/2010/08/13/centos5-5-install-openvpn.html
    http://tipupdate.com/how-to-install-openvpn-on-centos-vps/
    http://www.vps-tutorial.info/2011/01/10/openvpn-setup-xen-centos5/


    I still has got the same old trouble over and over again, so 3 days have flies I have given up and I have decided to switch to CentOS 5.5 64-bit instead of using 32-bit. If you know how to correct the problem for the iptables in CentOS 5.5 32-bit pygrub, I would be very grateful.

    However, this is the tutorial I'm using to install openvpn on 64-bit:
    http://sohonetwork.blogspot.com/2010/08/installing-openvpn-on-centos-55-x8664.html


    I have following the instructions correctly and when I have successfully installed openvpn on my virtual private server, I have entered the following command:

    Code:
    #openvpn /etc/openvpn/server.conf


    I get this:

    Code:
    Initialization Sequence Completed


    It said that my OPENVPN is ready to use. I have following the whole instructions toward the end after I have entered on that command. I have clicked on my windows start menu > control panel > network connection > create new connection > next > connect to the network at my workplace > virtual private network connection > my company name > do not dial the inital connection > my vps server ip> finish.

    I have entered the valid username and password the one I have input in the putty command that I have created and I have clicked on connect button, I get an error:

    Error: 800: Unable to estabish the VPN connection. The VPN server may be unreachable, or security parameters may not be configured properly for this connection.


    Do you know how to fix it?

    Any advice would be much appreicated.

    Thanks!