1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help! No Idea How To Fix Problem!

Discussion in 'Web Design' started by ForeverNever, Nov 15, 2010.

  1. ForeverNever

    ForeverNever Power Member

    Joined:
    Sep 17, 2008
    Messages:
    727
    Likes Received:
    365
    Hey everyone, I'm having a serious problem with my companies website, actually just the home page:

    Every time I update the page it adds a \ everywhere there is a ' or " and it's ruining my home page. For example, not only does it mess with only the content text, but I have maps embedded on the home page, and everywhere the code of the map has a " there is now a \ before it so no more maps!

    Some basic info: I'm running WP 3.0 with a theme I've never had a problem with (Delericon).

    Thanks
     
  2. c0rrup

    c0rrup Regular Member

    Joined:
    Jul 11, 2009
    Messages:
    256
    Likes Received:
    116
    Gender:
    Male
    Occupation:
    Internet Entreprenuer
    Location:
    Mars
    The script is escaping your ' and " with / to prevent malicious code....but it shouldn't because its your code. I am not sure, its something to do with the php script(s).
     
  3. Twizzler

    Twizzler Newbie

    Joined:
    Nov 4, 2010
    Messages:
    33
    Likes Received:
    7
    Occupation:
    Typing code.
    Location:
    Lost in cyberspace
    as c0rrup said something is set to escape the quotations....
    Depending on your setup with could be php configuration or the script itself.
    Basically on input any quotes will have a leading slash...
    Now you need to make it so that on output the leading slash is no longer there.
    There are several ways of going about this but you do need to code it since the script you are using has not done so.
    Basically it is a safety feature for SQL injection among various other things.