1. This website uses cookies to improve service and provide a tailored user experience. By using this site, you agree to this use. See our Cookie Policy.
    Dismiss Notice

Need help from Wordpress experts

Discussion in 'Blogging' started by PixelMathis, Nov 2, 2018.

  1. LordCameltoe

    LordCameltoe Jr. VIP Jr. VIP

    Joined:
    Mar 2, 2011
    Messages:
    685
    Likes Received:
    434
    Gender:
    Male
    Occupation:
    Adult Super Affiliate
    Location:
    Canada
    Maybe your site got hacked.

    1 - Turn off all plugins, revert to Twenty-Seventeen theme and check site speed. If it still persists, then there is something wrong with your server, SQL DB or DNS.
    2 - If speed is OK in step 1, turn your theme back on. If the site becomes slow again, then the problem is something in your theme isnt working well. Install WP-Debug and see what scripts/php process or hanging up your server.
    3 - If speed is OK in step 2, turn your plugins back on 1 by 1 until your site slows down.

    Thats pretty much all I can say without actually taking a look at the site.
     
    • Thanks Thanks x 1
  2. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Not hacked. that's for sure. It's just a few concurrent processes that are running and hogging server resources.
     
  3. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Thanks tried everything. changed theme etc etc but the issue still persists
     
  4. 1Enigma

    1Enigma Jr. VIP Jr. VIP

    Joined:
    Jun 24, 2016
    Messages:
    1,094
    Likes Received:
    404
    Gender:
    Male
    Occupation:
    Trapped between the Matrix and Bubble
    If you want me to go take a look on the inside let me know.
    Do you use WpMain? If not I suggest you create a SubDomain and use it.
    Do you have WpOptimize?
    Did you set the Site to Delete passed changes?
    Is the Lazy Load on?
    Sorry if these questions were already asked. Take a break from it and breath you'll figure it out.
    Look at your change log I crash my site by disabling a plug in.
     
    Last edited: Nov 2, 2018
  5. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Thanks for replying. No, I don't use wpmain and no i am not using wp optimize right now but I used to in the past. No, lazy load is on. The problem is not with optimizations but with "wait time".

    There are multiple instances of website.com/index.php running on my server. Is there a fix for it?
     
  6. 1Enigma

    1Enigma Jr. VIP Jr. VIP

    Joined:
    Jun 24, 2016
    Messages:
    1,094
    Likes Received:
    404
    Gender:
    Male
    Occupation:
    Trapped between the Matrix and Bubble
    Sorry again if this was asked. You clear the Cache?
    It sounds simple walk away for a couple of hours and the Ah Ha will hit you
     
    • Thanks Thanks x 1
  7. Montaa

    Montaa Registered Member

    Joined:
    Nov 6, 2015
    Messages:
    95
    Likes Received:
    18
    Gender:
    Male
    Occupation:
    Entrepreneur, SysAdmin
    Location:
    Tunisia
    Install Nginx for cPanel and reboot the server.
    It will helps.
     
    • Thanks Thanks x 1
  8. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Yes, did pretty much everything that needed done. I am not a wordpress novice by any means but having a hard time figuring the error out this time. It's the stray processes that are slowing the server, just need to find a way to disable them.
     
  9. 1Enigma

    1Enigma Jr. VIP Jr. VIP

    Joined:
    Jun 24, 2016
    Messages:
    1,094
    Likes Received:
    404
    Gender:
    Male
    Occupation:
    Trapped between the Matrix and Bubble
    You got it figured out yet?
     
  10. denchiro

    denchiro Jr. VIP Jr. VIP

    Joined:
    Dec 21, 2017
    Messages:
    173
    Likes Received:
    24
    Gender:
    Male
    The best thing is to use SSD hosting servers and there are different plugins for that purpose. Are you using any?
     
  11. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    I use Vultr.
     
  12. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Update - the host said several IPs are hitting your website and causing resource drain. I blocked them but the issue persists. The wait time for the domain is still very bad in Pingdom and nothing I do is working. Any help appreciated.
     
  13. 1Enigma

    1Enigma Jr. VIP Jr. VIP

    Joined:
    Jun 24, 2016
    Messages:
    1,094
    Likes Received:
    404
    Gender:
    Male
    Occupation:
    Trapped between the Matrix and Bubble
    Good! now you know the issue. Do you have Wordfence? They keep a pool of IPs to block.
     
  14. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Yes bocked those two IPs yet the issue persists. It seems only the desktop version of the website is hit
     
  15. SpoonFeeder

    SpoonFeeder BANNED BANNED

    Joined:
    Mar 19, 2017
    Messages:
    1,608
    Likes Received:
    1,990
    Gender:
    Male
    Add your site to the Cloudflare.

    Then Install and configure Fail2Ban and IPTables. Your problem should be solved.

    PM me if you need any assistance.
     
    • Thanks Thanks x 2
  16. mrtqzs

    mrtqzs Newbie

    Joined:
    Feb 9, 2009
    Messages:
    23
    Likes Received:
    13
    Gender:
    Male
    Sounds like a (D)DoS.

    CloudFlare will take care of the problem for a small scale attack.
     
  17. do do

    do do Registered Member

    Joined:
    Oct 31, 2018
    Messages:
    61
    Likes Received:
    9
    P3's not been updated for more then 4 years. Do you think it still does the job?
     
  18. PixelMathis

    PixelMathis Senior Member

    Joined:
    Jun 10, 2014
    Messages:
    1,195
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    Mad Methodologist
    Thanks for your reply but I just checked it's my ad network that's also causing issues. I already use Cloudflare so will try that.

    I am trying to take up the issue with my network's support atm. Thanks a lot.
     
  19. Montaa

    Montaa Registered Member

    Joined:
    Nov 6, 2015
    Messages:
    95
    Likes Received:
    18
    Gender:
    Male
    Occupation:
    Entrepreneur, SysAdmin
    Location:
    Tunisia
    Yes.
     
  20. mrtqzs

    mrtqzs Newbie

    Joined:
    Feb 9, 2009
    Messages:
    23
    Likes Received:
    13
    Gender:
    Male
    There used to be a tool in the past called (D)DoS-Deflate by MediaLayer which worked very well as a free script solution. It should still be available and will work today.
     
    • Thanks Thanks x 1