1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need experts dealing with Https (SSL issue)

Discussion in 'White Hat SEO' started by wingman80, Feb 27, 2013.

  1. wingman80

    wingman80 Regular Member

    Joined:
    Aug 13, 2009
    Messages:
    462
    Likes Received:
    49
    Home Page:
    Last week I applied https to my whole website but when i checked the page rank today, it turned back from 2 to 0. Any experts on http vs https. I really need to use https on the website but i checked the cache version, my website was deindexed. Please help
     
  2. ventr

    ventr Newbie

    Joined:
    Jan 29, 2013
    Messages:
    28
    Likes Received:
    4
    Make 301 to https and make sure your cert does not sound alarm in browsers.
     
  3. wingman80

    wingman80 Regular Member

    Joined:
    Aug 13, 2009
    Messages:
    462
    Likes Received:
    49
    Home Page:
    so you mean from https to http?
     
  4. Paranoid Android

    Paranoid Android Jr. VIP Jr. VIP Premium Member

    Joined:
    Jun 20, 2010
    Messages:
    1,459
    Likes Received:
    2,223
    Gender:
    Male
    Occupation:
    Pantie Thief
    Location:
    Native America
    I didn't know ssl would cause a problem. Google itself has ssl and it's still got a pr 10

    Sent from my HTC One X using Tapatalk 2
     
  5. the_demon

    the_demon Jr. Executive VIP

    Joined:
    Nov 23, 2008
    Messages:
    3,177
    Likes Received:
    1,563
    Occupation:
    Search Engine Marketing
    Location:
    The Internet
    Ummm, it's probably not an SSL issue. You do any black hat SEO lately? Google might have just caught up to you. :O

    --> Oh, and did you check Google Web Master Tools to see if they reported any specific crawl errors?
     
    Last edited: Feb 28, 2013
  6. wingman80

    wingman80 Regular Member

    Joined:
    Aug 13, 2009
    Messages:
    462
    Likes Received:
    49
    Home Page:
    nope, the site is entirely using white hat. there are lots of articles in SEOmoz regarding the SSL issue. Again, previously, we are using the http but we decided to use the https for security purposes. When I checked the page rank, it went from 2 to 0. I also have a problem with the redirection, the https://domain.com isn't redirecting to https://www.domain.com. It might create duplicate content for https://NON-WWW and https://WWW. We already redirected it using the alternative rel=canonical to http://www.domain.com.

    NOTE: In canonical, I've redirected it to http since there are some experiencing problems with https.