1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Meta Description not displayed properly - Please help!

Discussion in 'White Hat SEO' started by blackkaviar, Aug 14, 2012.

  1. blackkaviar

    blackkaviar Registered Member

    Joined:
    Jul 31, 2011
    Messages:
    91
    Likes Received:
    14
    I have a website using Joomla, and I've set the home meta description. However strangely for some keyword search, my site was still displayed in Google with default Joomla description "Joomla! - the dynamic portal engine and content management system."
    But with some other keyword, my site is already displayed with proper description.
    It seems to me that Google is indexing my sites with 2 versions?? But both are exactly the same URL (www.mysite.com). And I've set the Canonical URL properly.
    The site is still 3 months old.
    Any advise for this situation? Thanks in advance.
     
  2. SupremeDev

    SupremeDev Junior Member

    Joined:
    Jun 14, 2012
    Messages:
    183
    Likes Received:
    81
    Location:
    Planet Neptune
    When did you last updated your meta description?
    It may take some time for meta changes to appear in the index itself.

    To make sure that Google has indexed your description, you can do a "site:url" search. If it's not indexed yet, just wait.

     
  3. blackkaviar

    blackkaviar Registered Member

    Joined:
    Jul 31, 2011
    Messages:
    91
    Likes Received:
    14
    I updated the meta description about 2-3 weeks ago.
    The site is already indexed with proper description when I do "site:url" search. But as I said, for at least 1 of the keyword search the site was still indexed (or displayed) in SERP with Joomla default meta description.
     
  4. RA-ONE

    RA-ONE Regular Member

    Joined:
    Dec 31, 2011
    Messages:
    224
    Likes Received:
    21
    Gender:
    Male
    What is your website link ? PM me i might help you .