1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Massplanner not sharing link correctly?

Discussion in 'FaceBook' started by BRoss92, Jul 25, 2015.

  1. BRoss92

    BRoss92 Registered Member

    Joined:
    Apr 20, 2010
    Messages:
    80
    Likes Received:
    6
    Hi all,

    I'm having a bit of trouble with Massplanner and i'm not sure if this is a widespread problem or just mine, but whenever i try sharing a link to groups using Massplanner, it seems to only post the link and not actually show the Preview part, anyone else having the same problem? also any idea on how to fix this? All my meta tags on my page are correct including imagery..
     
  2. BassTrackerBoats

    BassTrackerBoats Super Moderator Staff Member Moderator Jr. VIP

    Joined:
    Mar 10, 2010
    Messages:
    15,916
    Likes Received:
    29,234
    Occupation:
    I don't actually have a job
    Location:
    Not England
    Home Page:
    What did support say when you asked them?
     
  3. Ryabinchik

    Ryabinchik Jr. VIP Jr. VIP

    Joined:
    Jan 4, 2010
    Messages:
    2,260
    Likes Received:
    102
    Gender:
    Female
  4. BRoss92

    BRoss92 Registered Member

    Joined:
    Apr 20, 2010
    Messages:
    80
    Likes Received:
    6
    I havent asked them yet as i wasnt sure if this was an easy issue to fix and its just something dumb on my part...


    Sometimes i've had the same issue manually too, but it seems more common with MassPlanner. I'm not sure if its a timing issue and Massplanner posts the post too fast before Facebook can display the preview.
     
  5. BassTrackerBoats

    BassTrackerBoats Super Moderator Staff Member Moderator Jr. VIP

    Joined:
    Mar 10, 2010
    Messages:
    15,916
    Likes Received:
    29,234
    Occupation:
    I don't actually have a job
    Location:
    Not England
    Home Page:
    The owner is on this site and a pretty good guy and I'm sure he would love to help you out... even if you think it is a dumb mistake on your part, I am sure he would not think so.

    Go ahead and ask him as it may be something that is a legit bug and he can fix it for everyone or it could be a simple user issue and he can guide you.
     
    • Thanks Thanks x 2
  6. BRoss92

    BRoss92 Registered Member

    Joined:
    Apr 20, 2010
    Messages:
    80
    Likes Received:
    6
    Ah nice one! That's something i totally didn't know, I'll get in contact with him and see if he can figure out why it seems to be happening. cheers man
     
    • Thanks Thanks x 1
  7. coitza

    coitza Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 26, 2007
    Messages:
    2,686
    Likes Received:
    696
    Occupation:
    freelancer
    Home Page:
    definitely write to support with any issue regarding Mass Planner we have a few great guys there that can help with everything. Though as you asked, the facebook sharing thing is quite a tricky one. For starters facebook acts strangely when it comes to sharing, some accounts can share with no problems others just can't, nothing shows up from auto-complete and there's nothing you can do about that, it's some internal thing from Fb that we haven't figured out yet and we even asked them, no reply though :)

    So what MP tries to do when this happens it just goes to the group in question and posts the link, it will show up like a share but it won't be counted as one, you will still get the traffic but not the actual share count.

    As for the preview, that is a Fb issue sometimes, it just doesn't show the preview, even when you do it manually, MP should try up to 3 times to get the preview though, if it's doing that on all post just contact us and we'll see what we can do.
     
  8. cleverk2

    cleverk2 Registered Member

    Joined:
    Mar 19, 2013
    Messages:
    70
    Likes Received:
    30
    You can use facebook debug tool. When you post the link there fb returns all the info that it scraps from the url, like og url, og image, og description, etc and shows how the preview would be posted on fb. Knowing this you can try fix the things that not shows on the right way and then click on "new scrap" or something like this, to fb clean his cache and update the preview :)


    developers.facebook.com/tools/debug/og/object/


    Coitza, you should try to see if mass can work together with this debug tool;
     
    Last edited: Jul 30, 2015